Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am new to latex under Linux and I recently installed LyX on an Ubuntu derivative and as we all know a lot of the provided templates don't work, one particular one that I am really interested in getting to work is the Revtex one, the error message I get is as follows:

Using revtex.lyx template:

LaTeX Error: File 'revtex.sty' not found. 

Description: 

 \renewcommand
                  {\usepackage}{\RequirePackage}^^M
*** (cannot \read from terminal in nonstop modes)

Using revtex4.lyx template: 

The layout file requested by this document,
revtex4.layout,
is not usable. This is probably because a LaTeX
class or style file required by it is not
available. See the Customization documentation
for more information.
LyX will not be able to produce output.

Now I do realize that the style and the layout files are missing, can anyone please guide me so I can install it it properly, I think I need to put the files somewhere LyX can see them, how do I do that?. Thank you very much for your time.

share|improve this question
add comment

1 Answer

I think you need to install the texlive-publishers Ubuntu package.

apt-get install texlive-publishers
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.