Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My document contains some landscaped pages using lscape package. When I compile the input file using latex-dvips-ps2pdf, the landscaped pages are automatically rotated so readers don't need to rotate their heads 90 degrees.

\documentclass{article}
\usepackage{lscape}
\usepackage{blindtext}
\usepackage[english]{babel}
\begin{document}
\blindtext
\begin{landscape}
\blindtext
\end{landscape}
\blindtext
\end{document}

Output using latex-dvips-ps2pdf

enter image description here

However, when the input file is compiled by xelatex, the landscaped pages are no longer automatically rotated, so we need to rotate our heads.

Output using xelatex

enter image description here

There is a statement in lscape documentation as follows,

I've made a minor improvement to lscape.dtx that I'd like to share with the world. My addition makes lscape rotate the PDF "paper" { not just the text on the page { when given the "pdftex" option. (Naturally, this works only with pdfLaTeX.) The result is that the text is viewable online without the reader having to rotate his/her head 90 degrees. The document still prints normally.

but when I use \usepackage[pdftex]{lscape}, the compilation fails.

Any idea to fix it?

share|improve this question
1  
there is a package pdflscape (ctan.org/pkg/pdflscape) might work better but I have not tested it –  Martin H Jun 9 '11 at 10:45
    
@Martin H: You should post it as an answer. (And it is correct) –  Leo Liu Jun 9 '11 at 10:46
2  
To quote Michael Flanders (before singing a song about a three-toed sloth): "I really ought to be hanging upside down to sing this, but I found this rather impractical, so if you can, perhaps you'd be kind enough to stand on your head to listen and we should get more or less the right effect." –  Loop Space Jun 9 '11 at 10:48

1 Answer 1

up vote 8 down vote accepted

Use the package pdflscape instead of lscape. It sets the Rotate attribute of the pdf

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.