Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For compiling a bibliography I'm using BibLaTex and for managing the bib-file I'm using BibDesk. The names-sequence is surname before given name(s) separated by a comma. For example:

Müller, Peter (2011): XYZ. Stuttgart: Verlag.

For incollections it is the same schema, but with added editor for example:

Müller, Peter (2010): XYZ. In: Meier, Hans (Hrsg.): ABC. Tübingen: Verlag, S. 5-29.

For the cases of incollections I'm having the problem, that the editor value is not always a sequence of given names and surname, sometimes it's an association like "Deutsche Gesellschaft für Sprachheilkunde". This will be compiled as follows:

Müller, Peter (2009): XYZ. In: Sprachheilkunde, Deutsche Gesellschaft für (Hrsg.): ABC. Hamburg: Verlag, S. 12-51.

Is there a easy way to clasp the associations name, best in BibDesk with the use of brackets. Or where and how do I need to define asscociation names as not splitable?

share|improve this question
    
Maybe "Deutsche Gesellschaft für Sprachheilkunde" should be treated as the publisher instead of the editor? Looking at the biblatex manual it seems all editorial fields are treated as name lists. –  N.N. Jun 13 '11 at 8:47

1 Answer 1

up vote 2 down vote accepted

In your bib file try

editor = {{Deutsche Gesellschaft für Sprachheilkunde}},

instead of

editor = {Deutsche Gesellschaft für Sprachheilkunde},
share|improve this answer
    
yeah, that works! do you know a if-command to test the editor field for curly brackets? Because know I need to turn off the small capitals in that cases of editors. –  MaKa TaBo Jun 13 '11 at 9:13
    
@Matthias Katerbow I'm afraid I don't understand your comment. You could please clarify it. –  N.N. Jun 13 '11 at 9:15
    
okay, sorry! I would like to add a if-command like follows to my declaration of incollection: If the editor field starts with a curly bracket, than the value of editor field should not be set to small capitals (or should be reset to \textnormal). –  MaKa TaBo Jun 13 '11 at 9:21
    
@Matthias Katerbow That sounds like another question. If you can't find an answer on the net I think you should post a new question on this site. –  N.N. Jun 13 '11 at 9:24
    
okay, I will search for in another way. Thanks for your help! –  MaKa TaBo Jun 13 '11 at 9:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.