Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When using the lettrine package, there are often additional spaces after the small caps:

space after small caps

It can get even bigger than that actually. It seems to me that this is because lettrine uses an mbox to prevent breaking the line, so the spaces inside the mbox are not modified properly.

Is that the case, and how can I get more equilibrated spaces after the small caps?

Note:

Even when only one word is used in the lettrine, the problem still shows up:using one word only

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I had made myself a wrapper for the \lettrine command to override the default values. After reading the lettrine manual again, I found out that it was better to override the length in a local lettrine.cfg file.

Then, to override the settings for each letter, I used \LettrineOptionsFor instead of personal macros. These go in a special file as defined by the \DefaultOptionsFile command in lettrine.cfg (that gets quite complex).

These two steps solved my problem.

For example, my lettrine.cfg contains:

\setcounter{DefaultLines}{3}                                                    
%%                                                                              
%% These are *decimal* numbers:                                                 
\renewcommand{\DefaultLoversize}{0.25}                                          
\renewcommand{\DefaultLraise}{0}                                                
\renewcommand{\DefaultLhang}{0.33}                                              
% Define default options per letter                                             
\renewcommand{\DefaultOptionsFile}{optfile.cfl}          

and then optfile.cfl contains:

% options per letter                                                            
\LettrineOptionsFor{A}{slope=5pt,findent=-0.5em}                                
\LettrineOptionsFor{J}{lraise=0.20,nindent=0em}                                 
\LettrineOptionsFor{L}{lraise=0,loversize=0.08,findent=-0.9em,nindent=1em}      
\LettrineOptionsFor{P}{findent=0.1em,nindent=0.1em}                             
\LettrineOptionsFor{Q}{lraise=0.30,loversize=0.15}  

The result for my example is:

lettrine with proper spacing

share|improve this answer

\lettrine's second argument is supposed to be just one word. If you want two like your example, use \textsc explicitly.

\documentclass{article}
\usepackage{lettrine}
\usepackage[margin=3in]{geometry}
\begin{document}
\lettrine Q{uel} \textsc{est} le travail de l'Esprit Comme nous
l'avons d\'ej\`a not lateur, etc.
\end{document}
share|improve this answer
    
That doesn't change the problem. The first word still has an additional space after it (see the new screenshot in the question). –  ℝaphink Jun 13 '11 at 10:45
    
@Raphink: You should post the code that produces that. I don't get that at all. –  TH. Jun 13 '11 at 10:53
    
The problem seems to come from a macro of mine which overrides \lettrine. I'm debugging it now. Thanks. –  ℝaphink Jun 13 '11 at 11:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.