Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have installed the draftwatermark package, but 'DRAFT' comes horizontaly in my document, not in diagonal. The same happens with the draftcopy package. Furthermore, modifying the angle option in either package only changes the vertical position of the DRAFT mention.

Can anybody help?


Additional information from the questioner, moved from an 'answer' to here

MiKTeX Problem Report
Message: Some PostScript specials could not be rendered.
Data: Error: /undefined in pgfo
Operand stack:
   --nostringval--   PermitFileReading   --nostringval--   PermitFileWriting   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1914   1   3   %oparray_pop   1913   1   3   %oparray_pop   1897   1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1166/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:95/300(L)--
Current allocation mode is local
MiKTeX GPL Ghostscript  9.00: Unrecoverable error, exit code 1

Source: Libraries\MiKTeX\Dvi\Ghostscript.cpp
Line: 372
MiKTeX: 2.9
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
Invokers: explorer/WinEdt
SystemAdmin: yes
PowerUser: no
Root0: C:\...\MiKTeX\2.9
Root1: C:\...\MiKTeX\2.9
Root2: C:\...\MiKTeX\2.9
Root3: D:\...\MiKTeX 2.9
UserInstall: C:\...\MiKTeX\2.9
UserConfig: C:\...\MiKTeX\2.9
UserData: C:\...\MiKTeX\2.9
CommonInstall: D:\...\MiKTeX 2.9
CommonConfig: C:\...\MiKTeX\2.9
CommonData: C:\...\MiKTeX\2.9)
share|improve this question

migrated from stackoverflow.com Jun 16 '11 at 20:06

This question came from our site for professional and enthusiast programmers.

4  
Since you haven’t shown us your code, nor your LaTeX configuration (which processor do you use …) we can only guess. This should work, and does for me. –  Konrad Rudolph Jun 16 '11 at 16:12
    
The answers to tex.stackexchange.com/questions/439/… are relevant to this question. –  Charles Stewart Jun 17 '11 at 7:54
1  
Please register and sync your two accounts here and on stackoverflow.com so I can merge them. This will give you ownership of the question again so you can add this info to it. Please only post solutions to the question in the answer section. Thanks. –  Martin Scharrer Jun 21 '11 at 9:17
add comment

4 Answers

Try using the background package.

Simple \usepackage{background} in the preamble should be enough.

I have just realised that I want to thank Mr. Medina, who is an active member here, for this very useful package!

share|improve this answer
add comment

The UK Tex FAQ has guidance on this: ‘Watermarks’ on every page. The eso-pic package, from those options, is documented in a blog post, How to insert watermark in LaTeX.

In addition to those recommendations, the watermark package provides flexibility. Take a look at the ncccropmark documentation for an example of its use.

Note that these packages tend to work only with the DVI backend or the PDF backend, not both.

share|improve this answer
    
+1 for the eso-pic blog post link as it contains fairly succinct code that works with pdflatex. –  atomicules Oct 19 '11 at 8:16
add comment

For my document I've needed watermark with timestamp and version control system revision id. My solution is: 1) generate single page pdf with watermark, I've used simple ruby script and prawn gem for pdf generation. 2) add watermark pdf as background for document pdf using pdftk.

share|improve this answer
add comment

Many thanks for your answers which contain many useful tips,

It seems the problem is with the latest version of Yap: the .dvi file generated here is read with a horizontal draft sign, but read at home, the sign appears as it should in italics

So I'll wait for the next version!

Best,

Armor

share|improve this answer
    
As I wrote in my first comment: "Assuming that you are trying to view the dvi in YAP: Switch in the view menu to the dvips render method. You can set this render method permanently in the options." –  Ulrike Fischer Jun 23 '11 at 9:16
    
thanks thanks thanks Ulrike, that's it, you're the best!! –  Armor Jun 24 '11 at 9:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.