Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've produced a .tex file using the pstricks package for figures and the Times font (via the mathptmx package). When the arXiv compiles this to a .pdf file it doesn't seem to have the necessary fonts embedded. It seems that that iPad and some other devices don't have the times font available, so some characters are missing when viewing the arXiv PDF on an iPad.

Does anyone know if it is possible to get the arXiv to produce a PDF with embedded fonts. The problem seems to have to do with the fact that pstricks necessitates a latex -> dvips -> ps2pdf compilation instead of pdflatex.

I'm aware of solutions like using pdftricks or converting the figures to PDFs and then using \includegraphics{...}, but the former seems to require some hand tweaking and the latter is a bit more fuss if I want to edit something in the future.

Any ideas?

share|improve this question

4 Answers 4

Are you running ps2pdf like

ps2pdf -dCompatibilityLevel=1.4 -dPDFSETTINGS=/prepress foo.ps foo.pdf

That seems to work for me.

Edit: I don't actually know what level of control arXiv provides though, so maybe using those arguments isn't possible.

share|improve this answer
    
yes, that works fine when I compile on my own computer, but I'm looking for a way to tell the arXiv to do something like that. When the arxiv decides to produce a pdf from my tex source, I don't get to tell it which command line options to use. –  Jeff G Aug 21 '10 at 9:45

I think the simple answer is "you can't directly". The way that fonts are embedded (or not) in DVI mode depends on the settings used by dvips. You can't influence them from within your TeX source. Of course, you can e-mail the people who run arXiv and ask them to ensure that the base fonts are always downloaded. They might do it if you are lucky.

share|improve this answer
2  
thanks - I'll give it a try emailing the arXiv people. Aside from that, the next best solution seems to be to compile each figure to a pdf, crop it, and write the tex file to be processed with pdflatex and use \includegraphics{figure.pdf}. ArXiv files processed by pdflatex seem to have the embedded fonts. –  Jeff G Aug 21 '10 at 17:35
    
I was assuming we were talking about DVI mode! –  Joseph Wright Aug 21 '10 at 18:24

You can submit a file 00README.XXX containing a line

myfonts.map fontmap

which will cause the arXiv software to issue a dvips commandline including the option -u+./myfonts.map. If your file myfonts.map specifies embedding of all the fonts you use (the "base 35" should be enough), then you should be able to acheive your goal. I haven't tried this, however, so I'd be interested to know if it works.

share|improve this answer

I received this very nice explanation by email from Thorsten S.

Asking arXiv admins with technical questions like this should always be your first choice. These should percolate up to the people that actually operate the TeX system at arXiv even if a little persistence may be necessary.

Indeed, arXiv does not embed the base 35 fonts in dvips generated PostScript. If you are familiar with texlive arXiv's setting in texmf/web2c/updmap.cfg i

dvipsDownloadBase35 false

however (as mentioned in previous responses) due to repeated reports of problems with arXiv generated PDF from pdflatex, despite the standards requirement that every PDF or PostScript interpreter must have the base 35 fonts, arXiv does embed the base 35 fonts in pdflatex generated PDF. This is the setting

pdftexDownloadBase14 true

in texmf/web2c/updmap.cfg

You say:

It seems that that iPad and some other devices don't have the times font available

They should, so if this is indeed the case arXiv would love to see some examples and get to the bottom of this.

The dvips fontmap advice above by Lev Bishop will work, however if there is a widespread problem arXiv should know about this.

It is also possible to control most PDF parameters and options via literal PostScript from a \special command in you TeX source, e.g. you could specify the list of fonts to always embed like this

   <</AlwaysEmbed [/Helvetica /Times-Roman]>> setdistillerparams

See

http://arxiv.org/help/faq/pdfrotate

for some more info on this. If this doesn't help, send email with details to arXiv for further advice.

Hope this helps
T. (yes, I do provide technical support for arXiv)

share|improve this answer
1  
"...despite the standards requirement that every PDF or PostScript interpreter must have the base 35 fonts...": See e.g. kb2.adobe.com/cps/322/322792.html - in brief, just embed always everything and you will really get what you want. –  Jukka Suomela Aug 22 '10 at 11:25
2  
I just tested this. I took a PDF document that uses Helvetica without embedding it. I opened the same document in Preview.app on Mac OS X, and in Adobe Reader on Windows (latest versions of everything). The document looks different; for example, it is easy to see that the glyphs of "1" and "R" look different in Helvetica and in the replacement font used by Adobe Reader. –  Jukka Suomela Aug 22 '10 at 11:47
    
It's OK to accept your own answer.... –  Lev Bishop Sep 15 '10 at 0:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.