Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Great site here. I have a question regarding Biblatex and Biber. My current .tex file structure looks like this in TeXworks:

\documentclass{article} 
\usepackage[T1]{fontenc} 
\usepackage{inputenc} 
\usepackage[backend=biber,style=authoryear]{biblatex} 
\addbibresource{mybib.bib} 

\begin{document} 
\printbibliography
\end{document}

When I run the Biber typeset, I get the following error:

INFO - This is biber 0.9.3
INFO - Logfile is 'myfile.blg'
FATAL - Cannot find control file 'myfile.bcf'! - did you pass the "backend=biber" option to BibLaTeX?

What am I doing wrong? Thanks in advance!

_________________________________(Edit by Richard 06/24/2011)

I applied the changes suggested below and although it worked for a single citation, when I include more than one, I get a PDF that only reads "Some text [A01]". Here is what I have now:

\listfiles

\documentclass{article}

\usepackage[backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@article{Lees:2011zi,
      author         = "Lees, J.P. and others",
      title          = "{Cross Sections for the Reactions $e^+e^- \to K^+ K^-
                    \pi^+\pi^-,\, K^+ K^- \pi^0\pi^0$, and $K^+ K^- K^+ K^-$
                    Measured Using Initial-State Radiation}",
      collaboration  = "The BABAR Collaboration",
      year           = "2011",
      note           = "* Temporary entry *",
      eprint         = "1103.3001",
      archivePrefix  = "arXiv",
      primaryClass   = "hep-ex",
}


@article{delAmoSanchez:2010fd,
  author         = "del Amo Sanchez, P. and others",
  title          = "{Analysis of the $D^+ \to K^- \pi^+ e^+ \nu_e$ decay
                    channel}",
  collaboration  = "The BABAR Collaboration",
  journal        = "Phys.Rev.",
  volume         = "D83",
  pages          = "072001",
  doi            = "10.1103/PhysRevD.83.072001",
  year           = "2011",
  eprint         = "1012.1810",
  archivePrefix  = "arXiv",
  primaryClass   = "hep-ex",
}


@article{delAmoSanchez:2010yp,
  author         = "del Amo Sanchez, P. and others",
  title          = "{Dalitz plot analysis of $D_s^+ \to K^+ K^- \pi^+$}",
  collaboration  = "The BABAR Collaboration",
  journal        = "Phys.Rev.",
  volume         = "D83",
  pages          = "052001",
  doi            = "10.1103/PhysRevD.83.052001",
  year           = "2011",
  eprint         = "1011.4190",
  archivePrefix  = "arXiv",
  primaryClass   = "hep-ex",
}


@article{delAmoSanchez:2010bx,
  author         = "del Amo Sanchez, P. and others",
  title          = "{Search for the Decay $B^{0} \to \gamma \gamma$}",
  collaboration  = "The BABAR Collaboration",
  journal        = "Phys.Rev.",
  volume         = "D83",
  pages          = "032006",
  doi            = "10.1103/PhysRevD.83.032006",
  year           = "2011",
  eprint         = "1010.2229",
  archivePrefix  = "arXiv",
  primaryClass   = "hep-ex",
}


@article{delAmoSanchez:2010zd,
  author         = "del Amo Sanchez, P. and others",
  title          = "{Measurement of the $B^0 \to \pi^\ell \ell^+ \nu$ and
                    $B^+ \to \eta^{(')} \ell^+ \nu$ Branching Fractions, the
                    $B^0 \to \pi^- \ell^+ \nu$ and $B^+ \to \eta \ell^+ \nu$
                    Form-Factor Shapes, and Determination of $|V_{ub}|$}",
  collaboration  = "BABAR Collaboration",
  journal        = "Phys.Rev.",
  volume         = "D83",
  pages          = "052011",
  doi            = "10.1103/PhysRevD.83.052011",
  year           = "2011",
  eprint         = "1010.0987",
  archivePrefix  = "arXiv",
  primaryClass   = "hep-ex",
}


@article{delAmoSanchez:2010bk,
  author         = "del Amo Sanchez, P. and others",
  title          = "{Search for the Rare Decay $B \to K \nu \bar{nu}$}",
  collaboration  = "BABAR Collaboration",
  journal        = "Phys.Rev.",
  volume         = "D82",
  pages          = "112002",
  doi            = "10.1103/PhysRevD.82.112002",
  year           = "2010",
  eprint         = "1009.1529",
  archivePrefix  = "arXiv",
  primaryClass   = "hep-ex",
}

@article{delAmoSanchez:2010vq,
  author         = "del Amo Sanchez, P. and others",
  title          = "{Observation of new resonances decaying to $D\pi$ and
                    $D^*\pi$ in inclusive $e^+e^-$ collisions near
                    $\sqrt{s}=$10.58 GeV}",
  collaboration  = "The BABAR Collaboration",
  journal        = "Phys.Rev.",
  volume         = "D82",
  pages          = "111101",
  doi            = "10.1103/PhysRevD.82.111101",
  year           = "2010",
  eprint         = "1009.2076",
  archivePrefix  = "arXiv",
  primaryClass   = "hep-ex",
}
 \end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Some text \autocite{A01}.

\printbibliography

\end{document}

______________________(EDIT BY RICHARD 06/27/2011)

When I compile this, I get almost perfect results, however there seems to be several "¿" throughout the document. Also, [hep-ex] is always displayed after each citation (I guess it prints the primaryClass at the end). Can I somehow disable the [hep-ex] from showing?

Also, would it be worth it to run XeTeX instead of latex when I compile? I'm looking for the best way to get unicode characters (preserve sub/superscripts, etc). Should I add the line, \usepackage[utf8]{inputenc} if I do this?

Thanks for all your help.

\listfiles

\documentclass{article}

\usepackage[backend=biber]{biblatex}

\usepackage{filecontents}

\usepackage[utf8x]{inputenc}

\begin{filecontents}{\jobname.bib}


@Article{Aubert:2007sea,
     author    = "Aubert, Bernard and others",
     collaboration = "BABAR",
     title     = "{Evidence for b ---> d gamma Transitions From a Sum of
              Exclusive Final States in the Hadronic Final State Mass
              Range 1.0-GeV/c**2 < M(X(d)) < 1.8-GeV/c**2}",
     year      = "2007",
     eprint    = "0708.1652",
     archivePrefix = "arXiv",
     primaryClass  =  "hep-ex",
     SLACcitation  = "%%CITATION = 0708.1652;%%"
}

@Article{:2010ip,
     author    = "del Amo Sanchez, P. and others",
     collaboration = "BABAR",
     title     = "{Dalitz-plot Analysis of B0 --> D0bar pi+ pi-}",
     journal   = "PoS",
     volume    = "ICHEP2010",
     year      = "2010",
     pages     = "250",
     eprint    = "1007.4464",
     archivePrefix = "arXiv",
     primaryClass  =  "hep-ex",
     SLACcitation  = "%%CITATION = 1007.4464;%%"
}


@Article{delAmoSanchez:2010rq,
    author    = "del Amo Sanchez, P. and others",
    collaboration = "BABAR",
    title     = "{Evidence for direct CP violation in the measurement of the
              Cabibbo-Kobayashi-Maskawa angle gamma with B-+ --> D(*)
              K(*)-+ decays}",
    journal   = "Phys. Rev. Lett.",
    volume    = "105",
    year      = "2010",
    pages     = "121801",
    eprint    = "1005.1096",
    archivePrefix = "arXiv",
    primaryClass  =  "hep-ex",
    doi       = "10.1103/PhysRevLett.105.121801",
    SLACcitation  = "%%CITATION = 1005.1096;%%"
}


\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

\nocite{*}

\printbibliography

\end{document}
share|improve this question
1  
a) Make sure you run latex first b) Cite at least one works included in your .bib file (or add \nocite{*} somewhere in your document). Does the error persist? –  lockstep Jun 23 '11 at 18:36
    
When you say "run latex", do you mean to type "latex myfile" in terminal? If so, I got the following message: ! Undefined control sequence. <recently read> \addbibresource l.5 \addbibresource {mybib.bib} –  Richard Jun 23 '11 at 18:42
    
I also included the \nocite{*} right after "\begin{document} " –  Richard Jun 23 '11 at 18:44
1  
\addbibresource was introduced in biblatex 1.2, so you need to update your TeX installation. biber 0.9.3 only works with biblatex 1.5. –  lockstep Jun 23 '11 at 19:04
    
I updated everything on TeX Live and still getting the same error. Do I have to update something manually? –  Richard Jun 23 '11 at 19:36

1 Answer 1

up vote 6 down vote accepted

This is a rather minimal, but compilable test example. Does this example (saved, say, as biblatextest.tex) compile for you without errors? If not, what does the logfile (biblatextest.txt), especially the section *File List, say?

EDIT: The proper compile sequence for the example (if one doesn't use a makefile like latexmk) is

-pdflatex biblatextest
-biber biblatextest
-pdflatex biblatextest

Note the use of biber as a replacement for bibtex!

\listfiles

\documentclass{article}

\usepackage[backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A.},
  year = {2001},
  title = {Alpha},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Some text \autocite{A01}.

\printbibliography

\end{document}

(The filecontents environment is only used to include some external files directly into the example, so that it compiles. It is not necessary for the solution.)

EDIT 2: In response to the updated question: In the code snippet \autocite{A01}, A01 is the citekey of the first (and only) bibentry in my .bib file (it starts with @misc{A01, misc being the BibTeX type). What do you expect when you cite an entry that isn't included in your .bib file?

EDIT 3: That's a new question, isn't it? ;-) To remove [hep-ex] from every bibliography entry, add the following to your preamble:

\AtEveryBibitem{\clearfield{eprintclass}}

And yes, XeLaTeX instead of pdfLaTeX may be worth a try. For details see Frequently loaded packages: Differences between pdfLaTeX and XeLaTeX.

share|improve this answer
    
I tried this using the Biber typset in TexXworks and it gave the same error. I opened terminal and typed -latex biblatextest -bibtex biblatextest -latex biblatextest -latex biblatextest and I got a PDF that read, "Some text [A01]." –  Richard Jun 23 '11 at 20:13
    
I don't know a "Biber" typeset in TeXworks, only a "BibTeX" one. Try "LaTeXmk" instead. (And when compiling from the terminal, use -biber biblatextest instead of -bibtex biblatextest!) –  lockstep Jun 23 '11 at 20:19
    
Now that works! I compiled in terminal with biber and the process worked great. Now in the PDF that I created, the characters are now in UTF-8? I changed the title to one that reads: Searches for the baryon- and lepton-number violating decays $B\rightarrow{}\Lambda{}c+l-$, $B-\rightarrow{}\Lambda{}l-$, and $B-\rightarrow{}\Lambda{}\ifmmode\bar\else\textasciimacron\fi{}l-$ I compiled and the PDF view was 100% accurate. So with Biber, those characters are converted to UTF-8? –  Richard Jun 23 '11 at 21:08
    
Indeed -- biber is able to decode LaTeX character macros into UTF-8. See section 2.5 of the biber documentation for details. –  lockstep Jun 23 '11 at 21:13
1  
@lockstep: NVM, used \ExecuteBibliographyOptions{doi=false, eprint=false} ... Thanks for all your help -- I appreciate it! –  Richard Jun 28 '11 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.