Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a long title for my beamer presentation and ue the \titlepage{} command. The title is automatically split over 4 lines. As I am using a tall font (arev), these lines are squashed together. I can use something like \newline \vskipt6pt where the line breaks occur to get roughly what I want (using \\ seems to insert a spurious comma). I am using the contributed Torino theme. This there a way to `automatically' increase this spacing for the title only?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

You can use \fontsize to control the font size (first argument) and the value of \baselineskip (second argument); usually, the value for the second argument is aprox. 20% more than the first argument, but you can use the value that best suits your needs:

\documentclass{beamer}
\usepackage[T1]{fontenc}
\usetheme{Torino}
\usepackage{arev}

\author{T.H.E. Author}
\title{\fontsize{28}{35}\selectfont A really really  really  really  really  really  really  really  really  really  really  long long title}

\begin{document}
\begin{frame}
  \titlepage
\end{frame}

\end{document}

enter image description here

share|improve this answer
    
Thank you very much for your prompt answer - changing the first parameter does change the font size, however, changing the second parameter does not appear to affect the output, even for the simple example you made. Any idea why not? –  prettygully Jun 27 '11 at 6:39
    
@prettygully: before posting the answer I did several tests in which I verified that changing the second argument would in fact modify \baselineskip. If you are getting something different, please add a minimal version of the problematic code to your question. –  Gonzalo Medina Jun 27 '11 at 13:05
    
This happened for your nice example. As it worked for you, I suspected that it might be my Torino files & downloaded them again. No idea why, but now all works as it should - thanks again. –  prettygully Jun 28 '11 at 0:00

Alternatively, you can edit the innertheme file and add something like

\setlength\lineskip{6pt}

right before the \inserttitle command.

If you want to use Torino with the alternativetitlepage option, you have to go this way, because there is a \offinterlineskip command that overrides what you set.

share|improve this answer
    
thanks very much; I'll try that for my next presentation. –  prettygully Aug 29 '11 at 23:09

about the spurious comma when using \\ in the title with the torino theme, there is a command redefinition in the template file beamerinnerthemefancy.sty line 81:

\def\\{,}\vbox{}\vskip-1.5ex

which redefines \\ as a colon and some space. If you change the line 81 from

  \@tempdima=\textwidth\textwidth=\paperwidth\hsize=\textwidth\def\\{,}\vbox{}\vskip-1.5ex%

to

  \@tempdima=\textwidth\textwidth=\paperwidth\hsize=\textwidth%\def\\{,}\vbox{}\vskip-1.5ex

you can use \\ in the title again

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.