Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I recently installed Ubuntu 10.04 over-top of Ubuntu 9.04, preserving my /home partition, but aside from that partition, it was a fresh install. I installed the texlive package (2009-7) from Ubuntu's main repository.

Now, when I try to run latex or pdflatex on a .tex file, I get the not so helpful error:

brian@thoralf:~/tmp$ pdflatex test.tex 
This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian)
 restricted \write18 enabled.
---! /home/brian/.texmf-var/web2c/pdftex/pdflatex.fmt doesn't match pdftex.pool
(Fatal format file error; I'm stymied)

What can I do to fix this problem?

share|improve this question
add comment

4 Answers 4

up vote 12 down vote accepted

[I asked, then search the net. I've made my answer community wiki so as not to look like I'm rep-hunting.]

There was a bug filed against ubuntu 10.04 beta. I'm somewhat surprised it's not been fixed as it makes latex rather useless.

One commentator on the bug thread said that deleting /home/.texmf-var worked for them. Worked for me, too.

share|improve this answer
1  
I guess this tells you the balance of users who use LaTeX doing 'over the top' installations against those who do fresh ones! –  Joseph Wright Aug 23 '10 at 5:58
add comment

I was having the exact same problem when I upgraded from 11.10 to 12.04 and then to 12.10 (even thought I'm a year behind). I could not compile latex, similar to the first post. This is what I was getting:

$ latex file_name.tex 
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/Debian)
restricted \write18 enabled.
---! /home/myUname/.texmf-var/web2c/pdftex/latex.fmt doesn't match pdftex.pool
(Fatal format file error; I'm stymied)

I used the solution stated above. Instead of deleting, I just renamed it. ie.

$ mv .texmf-var/ .texmf-var-BackUp

In my case, the .texmf-var folder was in the /home/myUname folder and not in /home folder. Now it compiles like it used to. Just wanted to add this in case others were looking for the same solution.

share|improve this answer
add comment

I was having the same problem, and saw this fix on a few community pages. I was hesitant to delete that directory, so I simply moved it. It totally worked, and now I can compile again. Thank you! I was afraid I'd lose billable hours over this, but it was an easy fix!

share|improve this answer
3  
~/.texmf-var contains only automatically generated content, so it is always safe to delete it. –  mpg Nov 10 '10 at 3:38
    
@mpg: That is not true for me; I've got a manual font entry in pdftex.map. (Maybe I should have done that differently??) –  Hendrik Vogt Nov 10 '10 at 14:46
    
HUm... good point. How did you add this line? updmap --enable Map=name.map or manual editing of the file? With updmap, information should (not 100% sure) be kept in TEXMFCONFIG (probably ~/.texmf-config for you). However, you need to rerun updmap after deleting TEXMFVAR, indeed. –  mpg Nov 11 '10 at 2:47
add comment

I had the same problem with Gummi and with texmath in LibreOffice (after upgrading from Ubuntu 13.04 to 13.10).

Deleting from ~/.texmf-var worked for me too.

share|improve this answer
1  
Welcome to TeX.SX! –  Claudio Fiandrino Mar 21 at 11:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.