Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to get my frames numbered. I'm trying it with the command \setbeamertemplate{footline}[frame number]

But it's not really working... I have a logo on my title page, which disappears with the above command. If I use \begin{frame}[plain] for my title page, the logo AND the section overview (I'm using the theme Goettingen) on the right disappear.

Is there a way to fix this? Here's my code:

\documentclass[xcolor=svgnames, handout]{beamer}
\usecolortheme[named=MidnightBlue]{structure} 
\usetheme{Goettingen}
\usepackage{array}
\usepackage{wrapfig}
\usepackage{graphics}
\usepackage{graphicx}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{amsthm}
\setbeamertemplate{navigation symbols}{}

\setbeamertemplate{footline}[frame number]

\mode<presentation>
{
  \usetheme{Goettingen}
   \setbeamercovered{transparent}
}

\title{title of the pres}
\subtitle{..}
\author{me}

\begin{wrapfigure}{r}{0.47\textwidth}
  \vspace{60pt}
  \begin{center}
    \includegraphics[width=0.20\textwidth]{logo}
  \end{center}
\end{wrapfigure}

\beamerdefaultoverlayspecification{}

\begin{document}

\bibliographystyle{plainnat}

\begin{frame}
\titlepage
\end{frame}

\section{Background}
\begin{frame}
   first frame....
\end{frame}
\end{document}

I'm happy about any ideas :)

share|improve this question
1  
The wrapfigure in the preamble doesn't make sense. Did you forgot a \logo{..} around it? Even then I personally wouldn't use wrapfigure. Also the \bibliographystyle line should be in the preamble. –  Martin Scharrer Jun 30 '11 at 14:59
    
Welcome to TeX.sx! You don't have to sign with your name since it automatically appears in the lower right corner of your post. –  Martin Scharrer Jun 30 '11 at 15:00
    
Thanks for the quick reply! Okay so now I'm trying it with \titlegraphic{\includegraphics[width=2cm]{mylogo}} and the section-bar on the right doesn't disappear. Looks a lot better than before, but I'd still like the logo to be right of the text of the titlepage (I mean on the right of my title and date and authorname). That's why I tried it with wrapfigure. –  Cammie Jun 30 '11 at 15:20
    
@Cammie: I see. Using wrapfigure on its own in the preamble like above is definitely wrong. It must be placed inside of the \title{..} or \titlegraphic{..} or similar macro. You could try \title{The title\rlap{\hspace{<distance>}\includegraphics[<options>]{<filename>]}}} to place it to the right of the title. Please don't forget to update your example above with any new code. –  Martin Scharrer Jun 30 '11 at 15:49
    
hmm... getting closer! But the figure still isn't next to the text, but creates a whole lot of space at the bottom. I used it like this: title{Title of my talk} \subtitle{ \vspace{2mm} \small A subtitle \\\vspace{4mm}\footnotesize ABC Conference 2011\\ University of ABC } \author{Cammie Lastname \\ Cammie's University} \date{\footnotesize{\today}} \titlegraphic{ \rlap{\hspace{8cm}\includegraphics[width=2cm]{unilogo}}} like I said, ideally, I'd like to have the logo on the right lower side of all the info. Thanks for the help! –  Cammie Jun 30 '11 at 16:17
show 1 more comment

1 Answer 1

Okay I found a way: with this package \usepackage{textpos} I can create the titlepage like this:

\begin{frame}\vspace{1cm} 
     \begin{minipage}[b]{0.6\linewidth}
       \maketitle 
     \end{minipage} 
     \begin{textblock*}{2cm}(7cm,-5.0cm) 
       \includegraphics[width=2cm]{figurename} 
     \end{textblock*} 
\end{frame}

and everthing looks great.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.