Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

We are having difficulties running PDF-XChange Viewer with pdflatex.

With configuration MiKTeX the viewer works fine but with TeX Live 2010 the viewer crashes on windows xp sp3. Any ideas what the difference in 3.1415926-1.40.11-2.2 3.1415926-2.3-1.40.12 could be that makes one crash the other not? Any idea how to update TeX Live 2010 to 2011? Uninstall old, install new? Thanks.

TeX Live 2010 pdflatex -version

pdfTeX 3.1415926-1.40.11-2.2 (Web2C 2010)
kpathsea version 6.0.0
Copyright 2010 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Compiled with libpng 1.4.3; using libpng 1.4.3
Compiled with zlib 1.2.5; using zlib 1.2.5
Compiled with xpdf version 3.02pl4

and

MiKTeX This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9) (preloaded format=pdflatex 2011.6.29)

share|improve this question
    
pdf-xchange viewer has the command line option "nolock=yes=OpenParameters" which enables it to refresh and preview the generated pdf (which it otherwise locked) but unfortunately after reload the viewer crashes on my Tex Live system and not on the MikTex installation of the support team so we suspect it is because of this version difference. –  panny Jul 1 '11 at 8:07
    
I cannot find anything about 'nolock' option in the documentation of pdf-xchange. Is that officially supported? What version do you use? –  Tomek Jul 1 '11 at 9:43
    
@Tomek it is officially supported and probably will be included in the documentation of the next release. In the windows version, after you add the pdfxcviewer.exe to your path, you can call the viewer with pdfxcviewer /A "nolock=yes=OpenParameters" my.pdf to view the pdf and have it overwritten by pdflatex. The viewer than asks you to reload the file which was not supported before the command line option since pdfxcview uses to lock the files it displays because people are allowed to edit the pdf's and save them. –  panny Jul 1 '11 at 10:12
2  
@panny Thanks for the info. Indeed, the latest version of pdf-xchage (2.5.196) supports this option (as I found on their forum, nothing in docs), but I would call it experimental rather than official at this point. Further, I tried with pdflatex from TL'10, same version as yours, and I don't get any crashes (tested on Windows 2003). –  Tomek Jul 1 '11 at 11:10
2  
@Jasper: If you want to get it, just install it, then make sure everything works as expected, wait at least a few weeks, and only then uninstall TL2010. Uninstalling the previous version first is not recommended unless you're badly lacking disk space. –  mpg Jul 1 '11 at 18:09
add comment

1 Answer

As suggested in the comment by @Jasper, first you must uninstall TeXLive2010 and install the new version, TeXLive 2011 in your case. This solves the issue, as pointed out in the comments: it has to do with a problem related to pdf-xchange's nolock=yes=OpenParameters command line option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.