Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using Palatino for the content and I have a problem displaying \chi in math mode. The problem happens when I have a roman formatting in math, e.g., vector x, X, and χ; the χ turns to some other character.

The minimal example

\documentclass[12pt,oneside,english,titlepage, a4paper, fontsize=12pt]{scrbook}

\usepackage{mathpazo}
\usepackage{geometry}
\geometry{letterpaper}
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{epstopdf}


%show vectors in bold
\renewcommand\vec[1]{\mathrm{\mathbf{#1}}}
%end renew commands

\title{Brief Article}
\author{The Author}
\begin{document}

\noindent Three different systems of reference are used within this
work. Structural deformations are described in the Lagrangian or material
formulation. The corresponding Lagrangian coordinate system denoted
by $\vec{X}$ is associated with the particular material points. The Eulerian or
spatial system of reference denoted by $\vec{x}$,
in which the observer is fixed in space and looks at the fluid passing.
In the ALE description of the motion, a third reference system, denoted
by $\vec{\chi}$.
\end{document}

which produces the following image:

chi is not shown correct

What I would like to have is this [1]:

chi is shown correct

How can I fix this?

[1] The difference is that I removed \usepackage{mathpazo} from the top.

share|improve this question
    
A minimal example would be helpful. –  Seamus Jul 4 '11 at 13:22

3 Answers 3

up vote 7 down vote accepted

As long as your vectors are only Roman or Greek letters, the following works

\usepackage{bm}

%show vectors in bold
\DeclareRobustCommand\vec[1]{%
  \ifcat\noexpand#1\relax
    \expandafter\bm
  \else
    \expandafter\mathbf
  \fi{#1}}
%end renew commands

Your \mathrm serves no purpose. The problem is that there's no Greek letter in the font used by \mathbf, so we resort to the \bm macros of package bm.

Caution This works only with one letter as the argument.

An alternative can be simply

\usepackage{bm}
\renewcommand{\vec}{\bm}

but Roman letters will be in boldface (math) italic.

share|improve this answer
2  
The \mathrm makes \vec{X} an upright letter, doesn't it? It serves no purpose for greek letters –  Seamus Jul 4 '11 at 13:46
    
@Seamus \mathXY commands work differently from \textXY commands: their effect are not cumulative, since they simply choose a different alphabet. The usual alphabet associated to \mathbf is "upright boldface". –  egreg Jul 4 '11 at 13:54
    
Ah right. I see that now. Thanks for clarifying. –  Seamus Jul 4 '11 at 14:01
    
Isn't \let\vec\bm simpler than \renewcommanding it? Or is \leting things a bad idea? –  kahen May 3 '12 at 19:58
    
It's not a bad idea; with \renewcommand we would always use the current meaning of \bm; with \let the meaning is frozen. –  egreg May 3 '12 at 20:00

Using \newcommand\vec[1]{\boldsymbol{#1}} makes your chi appear bold. Unfortunately, I can't get it to play nice with \mathrm

share|improve this answer

try this setting instead:

\usepackage[T1]{fontenc}
\usepackage[uprightgreeks]{kpfonts}

the kpfonts are similiar to the palatino fonts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.