Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use the listings package for code listings and I turned the line numbers on. But they appear left of the paragraph. I want them inside the paragraph. In the documentation it looks just right. Here is my code:

\documentclass[12pt,a4paper]{scrartcl}
\usepackage{listings}
\lstset{numbers=left}
\begin{document}
\section{Test}
Test
\begin{lstlisting}
    test()
\end{lstlisting}
\end{document}
share|improve this question
    
If you accept an answer you probably find it useful and hence you should upvote it. –  N.N. Aug 8 '11 at 13:38
add comment

1 Answer

up vote 6 down vote accepted

use

\lstset{numbers=left,xleftmargin=2em,frame=single,framexleftmargin=1.5em}
share|improve this answer
    
ok that helps, but I use frame=lines and the lines change too with this setting –  dbrettschneider Jul 5 '11 at 12:38
    
I tried framexleftmargin=-1.5em but it ignores the minus –  dbrettschneider Jul 5 '11 at 12:41
    
see edited answer –  Herbert Jul 5 '11 at 12:55
    
ah thanks, misunderstood the framexleftmargin –  dbrettschneider Jul 5 '11 at 13:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.