Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am new to MikTeX. I have set up a texmf tree and included that into MikTeX (works OK because the style files are found). But the font in that directory cannot be used yet, because the pdftex.map does not have the info from my map file.

I run initexmf --edit-config-file updmap (also with --admin) and enter (as the only line)

Map mymap.map

then I run updmap (also with --admin and --verbose), my mapfile gets listed as Parsing "c:\Path\to\mapfile.map".... But pdftex does not work, because it fails with:

Trying to make PK font abc8x at 600 DPI...
...

When I manually include the map file in first line of my .tex file

 \pdfmapfile{+mymap.map}

everything is OK.

How do I do without the \pdfmapfile{...} line?

share|improve this question
    
is the map file in a directory where TeX will search for files? –  Herbert Jul 6 '11 at 12:28
    
Yes. It is in the texmf directory that I have added in MikTeX (the one with the style file that gets loaded) below texmf/fonts/map/dvips/mymap.map (and also below pdftex/mymap.map). –  topskip Jul 6 '11 at 12:31
    
and you also updated the file name data base? So that kpsewhich mymap.map finds the file? –  Herbert Jul 6 '11 at 12:33
    
Assuming that you did run initexmf and updmap without the --admin key: Update the FNDB with initexmf -u. Run again updmap --verbose. Try again your font. If it doesn't work: Check which pdftex.map updmap writes. Check if this it the map file your document use (see end of the log-file). Check if this pdftex.map contains the entries of your map. –  Ulrike Fischer Jul 6 '11 at 12:35
2  
@Patrick: no not strange. You have a multi user installation with an admin and a user mode. And in contrast to the widespread prejudice the admin mode is not the more powerful. In general user settings (packages, configurations, map files, texmf trees...) take precedence over the default settings from the admin. What you do in user mode will normally work directly and without problems - but only for this user. What you do in admin mode will work for all user - as long as they don't have personal settings. –  Ulrike Fischer Jul 6 '11 at 14:23

1 Answer 1

up vote 6 down vote accepted

(Converting Ulrike's comments to an answer)

Assuming that you did run initexmf and updmap without the --admin key: Update the FNDB with initexmf -u, run updmap --verbose then try again your font. If it doesn't work: Check which pdftex.map updmap writes. Check if this it the map file your document use (see end of the log-file). Check if this pdftex.map contains the entries of your map.

Explanation

You have a multi user installation with an admin and a user mode. And in contrast to the widespread prejudice the admin mode is not the more powerful. In general, user settings (packages, configurations, map files, texmf trees, ...) take precedence over the default settings from the admin. What you do in user mode will normally work directly and without problems - but only for this user. What you do in admin mode will work for all user - as long as they don't have personal settings. See for more in Difference between administrative and user mode of MiKTeX.

Note

Exactly the same happens on Unix systems. Running updmap and not updmap-sys (with superuser privileges) will leave a pdftex.map in the user space that will have precedence over the system wide one. This may have undesirable effects in case of an update to the distribution that changes the font subsystem.

Example

(from http://docs.miktex.org/manual/advanced.html, using problem cited in Font display error in windows, which produces the error The mathkerncmssi source file could not be found.)

  1. Run initexmf --edit-config-file updmap.

  2. Insert the following line at the end of the file (relevant to the font in question):
    Map sansmathaccent.map

  3. Save the file and close the editor.

  4. Run initexmf --mkmaps to rebuild the font map files.


For a general guidance see Manual font installation.

share|improve this answer
1  
@StevenB.Segletes This is a CW answer made up by me from comments: feel free to edit! –  Joseph Wright Apr 21 at 14:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.