Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The default behavior for WinEdt 6 seems to be to insert 4 spaces when you hit the Tab key. I'd like to change this to 2 spaces. I managed to do this in WinEdt 5, but can't seem to figure out how to make the change in WinEdt 6

share|improve this question
add comment

2 Answers

Version 6 has a new options interface that is customized by editing INI files. You'll want to edit the Tab.ini file.

From the Options menu, select Options Interface.... Expand the Font Schemes tree and open the Tabs item. Change line 15 to TAB_LENGTH=2 and save. Right-click on the Tabs item and select Load Script.

You can save all of your changes from the default options in a single script. How to do this is described in Help.

This new interface might be a pain to use, but you can actually configure almost everything. I've set up many different shortcut keys with popup menus to remind me of the key sequences in case I forget them.

share|improve this answer
add comment

In the four months I've been using it, WinEdt 6.0 [Build: 20110315] has proved pretty robust, but at least in this area it appears to be a little buggy.

To change tab settings, first off as Audrey described, from the Options / Options Interface... / Tabs panel, change TAB_LENGTH=2 in tabs.ini, then click the Load Current Script button (leftmost button immediately above the Configuration panel) just as you would to apply any other configuration change.

However, you'll probably notice that that doesn't seem to make any difference to the editor's tabbing behavior.

Here's the trick you'll want to apply to fix things. Bring up the Font Schemes file from the the Configuration panel (NB, make sure you're looking at fonts.ini, not font.ini). Make a superficial edit anywhere and save, then click Load Current Script on it. There's no need to change or comment out any of the TAB_LENGTH settings you might find there. Simply leave them alone. The mere act of (re)loading fonts.ini is enough to "activate" your TAB_LENGTH=2 setting from tabs.ini. As very odd as that might seem.

share|improve this answer
    
That does seem odd. I didn't encounter this problem. Perhaps you could let the WinEdt team know. –  Audrey Aug 30 '11 at 2:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.