Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm creating a resume based off of the example tutorial HERE. It's fairly simple, actually -- just a two columned table with dates on the left and job on the right. I prefer bullets vs. a paragraph for the explanations, and also liked the look of a vertical seporator, so I tried to go with something like this:

\begin{tabularx}{0.97\linewidth}{>{\raggedleft\scshape}p{2.75cm}|X}

\small{09/2008 -- Present} & \textbf{Title} \\
& Company Name Here $\cdot$ City, State
\begin{itemize}[itemsep=4pt,parsep=0pt,topsep=3pt]
    \item Some stuff that I did to fill in a bullet.
    \item Some more stuff that I did just to make sure I have one example of a two
      line bullet here for variety's sake.
\end{itemize} \\
\end{tabularx}

I'm using the enumitem package to play with itemize spacing, and this is the tabularx package. as recommended in the linked blog post.

I get an extra line of vertical separator in the table when I do this, like so (see how the separator carries down about a line after the text stops?):

shot of extra separator line

I also tried switching to regular 'ol tabular but got the same results:

\begin{tabular}{r|p{13.7cm}}

\small{09/2008 -- Present} & \textbf{Title} \\
& Company Name Here $\cdot$ City, State
\begin{itemize}[itemsep=4pt,parsep=0pt,topsep=3pt]
    \item Some stuff that I did to fill in a bullet.
    \item Some more stuff that I did just to make sure I have one example of a two
      line bullet here for variety's sake.
\end{itemize} \\
\end{tabular}

Lastly, on a fluke, I had an extra end brace inserted in tabular and found a magic fix! Switching that \end{tabular} to \end{tabular}} gave some errors, but gives me this:

shot of proper separator

See the difference? I tried the same with tabularx (since it makes an easier time for specifying widths and such), but it doesn't even render the table with them present.

Any thoughts as to what's going on and how I can legitimately get rid of that extra line without "cheating"? In my skimming, I ran across people trying to get rid of top whitespace in tables (like HERE), but using the \compress trick didn't fix my problem either.

share|improve this question
1  
Your images were uploaded using a 'normal' Imgur account. Could you re-upload using the 'include graphic' button in the editor: this uses a paid-for account and so the images will not expire. –  Joseph Wright Sep 6 '12 at 21:24

3 Answers 3

up vote 4 down vote accepted

Not a real fix, but if you say, as the final lines of the itemize,

line bullet here for variety's sake.\vspace*{-\baselineskip}
\end{itemize} \\

you get rid of that vertical space.

share|improve this answer
    
Huh. That does, indeed, work. Any idea why 1) itemize is inserting a "ghost line" after the end of the list or 2) why this works to fix it? Is it just inserting negative space afterward? –  Hendy Jul 7 '11 at 20:46
    
I don't know precisely; apparently TeX goes into typesetting a new empty paragraph after the list. So I defeat it by inserting a negative space that compensates it. –  egreg Jul 7 '11 at 20:49
    
Interestingly, I got an overfull hbox with your code until I added \noindent in front of the table. –  mafp Apr 18 '13 at 16:38

You could wrap the itemize in a minipage to get rid of the space afterwards, I think.

\documentclass{article}

\usepackage{tabularx}
\usepackage{enumitem}

\begin{document}

\begin{tabularx}{0.97\linewidth}{>{\raggedleft\scshape}p{2.75cm}|X}

\small{09/2008 -- Present} & \textbf{Title} \\
&
\begin{minipage}[t]{\linewidth}
Company Name Here $\cdot$ City, State
\begin{itemize}[itemsep=4pt,parsep=0pt,topsep=3pt]
    \item Some stuff that I did to fill in a bullet.
    \item Some more stuff that I did just to make sure I have one example of a two
      line bullet here for variety's sake.
\end{itemize}
\end{minipage} \\
\end{tabularx}

\end{document}

Result:

result

You may need to add an after=\strut option to that itemize if you find that it's too close to table rows you may add below it. I've got more answers and links on another answer of mine about removing space above and below itemize in a table.

share|improve this answer

I just had the same problem- turns out I had an errant \\ at the end of my final \item.

Looks like you also have an extra \\ after \end{itemize} - try deleting it and see if that helps- worked for me!

share|improve this answer
1  
The \` after \end{itemize}` is needed to end the table row. Also, the OP has no `\` after the final item, if the MWE is to be believed. –  mafp May 15 '13 at 7:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.