Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.
  1. Which is the correct syntax for -dAutoRotatePages=/None passed to ps2pdf in Windows?

    ps2pdf -dAutoRotatePages=/None input.ps output.pdf 
    

    or

    ps2pdf -dAutoRotatePages#/None input.ps output.pdf
    

    ?

  2. Why is there a slash in /None?
  3. And why cannot we use = in Windows?
share|improve this question
1  
Isn't this parameter not simply passed to Ghostscript? So you would have to look for the correct syntax of Ghostscript. The slash comes from the PostScript syntax I think. –  Martin Scharrer Jul 10 '11 at 14:06

2 Answers 2

up vote 4 down vote accepted

For Windows

ps2pdf -dAutoRotatePages#/None input.ps output.pdf

pdf is a subset of PostScript where functions are defined as /<name>

share|improve this answer
4  
no idea, I am a Linux user, which makes live easier ... :-) –  Herbert Jul 10 '11 at 14:09
2  
life is live ... :-) –  Herbert Jul 10 '11 at 14:16
    
It should be "which makes for an easier life". You can't use "live", which is a verb, in that context. –  egreg Jul 10 '11 at 14:27
    
@xport: Please don't. It is "makes life easier" of course as any dictionary will tell you. It's a common error made by Germans. –  Martin Scharrer Jul 10 '11 at 14:29
10  
The = is used in batch files as delimiter to separate arguments (like space or tab). See support.microsoft.com/kb/35938/en-us. –  Ulrike Fischer Jul 10 '11 at 14:39
  1. ps2pdf is a batch file.
  2. In MS-Windows, batch file uses = as a dilimiter as discussed in the link given by Ulrike. I copied and pasted here for the sake of convenience.

    Using batch files in MS-DOS, it is not possible to include an equal sign as an argument to a batch file. The batch file parser considers this to be a delimiter, such as a space or tab character. Thus, using the following one-line batch file (named TEST.BAT):

    echo %1 %2 
    

    If the following is entered:

    TEST one=two 
    

    it would produce the following output

    one two 
    

    which shows that the batch file parser considers "one" the first argument, and "two" the second argument, with the equal sign being a delimiter. This makes it impossible to enter equal signs in batch files as command-line options.

  3. But don't get confused with latex -interaction=nonstopmode which uses = here. latex is not a batch file. Period! This is a confusion that I had just experienced. :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.