TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Windows 7 and just installed Texmaker. Is it possible to configure it in such a way that I can run Latex -> BibTex -> Latex -> Latex?

I looked at the configuration options here:

enter image description here

I tried replacing the bibtex % line with pdflatex -synctex=1 -interaction=nonstopmode %.tex bibtex % pdflatex -synctex=1 -interaction=nonstopmode %.tex but that did not work.

What should I change to be able to run this command?

share|improve this question
up vote 14 down vote accepted

Yes, go to Options->Configure TeXmaker->Quickbuild->User->Wizard, and then add the commands in succession. You can also do this manually by separating adjacent commands with a vertical bar.

share|improve this answer
Perfect! Thank you. – celenius Jul 10 '11 at 19:04
Can you share an commands for Latex -> BibTex -> Latex -> Latex? – user29167 Apr 17 '13 at 5:33
@Jacek: Maybe you are interested in the following question/answer: tex.stackexchange.com/questions/107989/… – Marco Daniel Apr 17 '13 at 6:10

Under "Quick Build", click User and type this:

pdflatex %.tex|bibtex %.aux|makeindex %.nlo -s nomencl.ist -o %.nls|pdflatex %.tex|pdflatex %.tex|"C:/Program Files/Adobe/Reader 11.0/Reader/AcroRd32.exe" %.pdf
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.