Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Is it possible to set the number of names to appear in a bibliography entry differently from the maximum number of names that appear in the citation key (using alphabetic style)?

For example,

[ABCD06] Alice, Bob, Carol, and David. "Title", 2006.
[ABC+06] Alice, Bob, Carol, David, and Eve. "Title Revisted," 2007

This is how alpha behaves in BibTeX. With four authors, all are listed in both the entry and the citekey. With five or more, all authors are still listed in the entry but only the first three (with a +) are listed in the citekey.

I played a little (without luck) with maxnames, maxcitenames, and mincitenames but figured it will be quicker to just ask.

share|improve this question
1  
maxcitenames and maxbibnames isn't it? At least in the latest biblatex... –  Seamus Jul 12 '11 at 20:24
2  
or add a different maxnames option to the \printbibliography command itself? –  Seamus Jul 12 '11 at 20:24

1 Answer 1

up vote 11 down vote accepted
\documentclass{article}

\usepackage[style=alphabetic,maxnames=4,minnames=3,maxbibnames=99]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{test1,
  author = {Alice and Bob and Carol and David},
  year = {2006},
  title = {Title},
}
@misc{test2,
  author = {Alice and Bob and Carol and David and Eve},
  year = {2007},
  title = {Title revisited},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Some text \autocite{test1,test2}.

\printbibliography

\end{document}

EDIT: My answer relies on a message from Philipp Lehman, the author of biblatex, at de.comp.text.tex on December 29th, 2010. The significant quote (translated by me):

Relevant for the "alpha" labels is the value of maxnames/minnames set at \begin{document}. The labels are fixed from this point forward. You may freely choose how many names to display afterwards.

EDIT2: When using the package option maxbibnames=99, maxnames/minnames must be set in addition; setting maxcitenames/mincitenames won't produce the desired "alpha" label format.

share|improve this answer
    
Perfect! Thank you! –  PulpSpy Jul 12 '11 at 20:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.