Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

scrlttr2 seems to set a line with the address on it. I can't figure out which of the many scrlttr2 options turns it off.

\documentclass{scrlttr2}
\setkomavar{fromname}{Seamus}
\setkomavar{fromaddress}{Earth\\
  Solar System\\
  Milky Way\\
  The Universe}
\begin{document}
\begin{letter}{TeX\\
    Stackexhange\\
    dot com\\
    The internet}
  \opening{Dear TeXnicians}

  I am having trouble with the above ruled line

  \closing{Yours hopefully}
\end{letter}
\end{document}

this line!

I am trying to remove the rule, and the text highlighted...

share|improve this question

2 Answers 2

up vote 6 down vote accepted

To remove the line and the text, add backaddress=off to the class options. To remove just the line, add backaddress=plain to the class options.

share|improve this answer
    
That's great thanks. But this still seems to leave loads of whitespace where the backaddress used to be... –  Seamus Jul 15 '11 at 12:16

Set the KOMA variable backaddress to be empty:

\setkomavar{backaddress}{}

or see Michael's suggestion.

To remove the reserved space, set the pseudolength backaddrheight to 0:

\makeatletter
\@setplength{backaddrheight}{0pt}
\makeatother
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.