TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a newbie to TeX. I want to use XeLaTeX for my CV, but when I try to compile with Texmaker. a get an error saying: This is XeTeX, Version 3.1415926-2.2-0.9997.4 (TeX Live 2010) restricted \write18 enabled.

kpathsea: Running mktexfmt xelatex.fmt
I can't find the format file `xelatex.fmt'!

What is the problem here? How can I fix it?

share|improve this question
Reinstalling via sudo apt-get install --reinstall texlive-xetex did the job for me. – user23678 Dec 26 '12 at 16:14

try to run sudo fmtutil-sys --all which should create all missing format files.

share|improve this answer
It still replys with:This is XeTeX, Version 3.1415926-2.2-0.9997.4 (TeX Live 2010) restricted \write18 enabled. kpathsea: Running mktexfmt xelatex.fmt I can't find the format file `xelatex.fmt'! – cyberscientist Jul 16 '11 at 7:58
What does the summary output of the above command say? – Herbert Jul 16 '11 at 8:02
there output ofcommand was very long, I dont know how to retrive and display it here. – cyberscientist Jul 16 '11 at 23:16

If you installed TeX from the repositories of your Linux system, you could reinstall the xetex package from a repository.

  • Redhat/Fedora: sudo yum reinstall texlive-xetex

  • Debian/Ubuntu: sudo apt-get install --reinstall texlive-xetex

share|improve this answer
Thanks for your reply. I did a reinstall of texlive-xetex.But I still have the same error. – cyberscientist Jul 16 '11 at 23:15
Thanks, your answer worked for me :) – Yan King Yin Nov 16 '15 at 6:51

Make sure that you have the proper LaTeX packages installed in addition to the XeLaTeX ones.

In my installation of TeX Live on a Mac, I initially didn't have the latex or latex-bin packages installed, but I did have xetex installed. Running xelatex would result in the error message given by cyberscientist.

Try the following to install the LaTeX packages and generate xelatex.fmt:

tlmgr install latex latex-bin
fmtutil ---all

If you need to do things systemwide rather than in your user directory, try

sudo tlmgr install latex latex-bin
sudo tlmgr-sys --all

For me this unintuitively resulted in generation of xelatex.fmt. xelatex now runs successfully.

share|improve this answer
The last command should be sudo fmtutil-sys --all, shouldn't it? – egreg Oct 12 '12 at 22:52

I recommend reinstalling TeX Live.

This is how I got TeX to run (in Sabayon linux--- based on Gentoo linux), and stop it saying it couldn't find tex.fnt. Installing Texlive anew worth is a try, since it worked for me.

share|improve this answer
Welcome to TeX.SX! You may have a look on our starter guide. Your answer is more of a comment rather than full answer. Once you’ve gathered 50 reputation points on this site, you’ll be able to comment and with 15 rep you can upvote answers. – texenthusiast May 23 '13 at 3:46
@texenthusiast: I think this answer is valid. We already have reinstalling recommended in a comment, but it deserves to be an answer. I've edited the answer to make it a bit clearer (which I couldn't do with a comment). – Charles Stewart May 23 '13 at 8:55
@CharlesStewart should we include the command line tweaks mentioned in the comment above inside the answer to bring strength and means. Also its not clear to me why reinstall did not work ?. In my opinion. This answer does not add value in addition to Stefan's answer which gives the same with more tweaks – texenthusiast May 23 '13 at 9:04
@Texenthusiast: I had overlooked Stefan's answer - this could be flagged as "duplicate answer". – Charles Stewart May 23 '13 at 9:27
@CharlesStewart, texenthusiast: It's OK if multiple users post similar answers. In this case the voting system not flagging should be used to separate good (+1), ok (0) and bad (-1) answers. – Martin Scharrer May 24 '13 at 5:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.