Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I tried to use user command "xelatex %" or change quick build to "User" with "xelatex %", but neither one gives any output when executed. Why is that?

share|improve this question

2 Answers 2

Try to run it "by hand" to see what output do you get. Open the Terminal for Linux/Mac OS X or Command Prompt in Windows and then run:

xelatex <name>.tex

I also tested it with "Options-> Configure TeXmaker" and changing the latex command to xelatex. When I now run it with the coice latex it works. enter image description here

share|improve this answer
    
It's fine. And such user command can be run without problem under TeXMakerX (but I don't like the X version). –  C.R. Jul 17 '11 at 12:55
    
@Karus: see ma edited answer. I just tested it whith changing the latex command –  Herbert Jul 17 '11 at 13:43
    
It didn't work. Guess it has something to do with my system. –  C.R. Jul 17 '11 at 14:01
    
@Karsus: On my OS X with TexmakerX I have to give the full path to a command: "/usr/texbin/xelatex" %.tex instead of xelatex %.tex –  Tobi Jul 17 '11 at 14:51
    
@Karsus: do you have a export PATH=/usr/local/texlive/.../:$PATH in your local config setting? This is needed for TeXLive from tug.org/texlive –  Herbert Jul 17 '11 at 15:37

To solve the proble in my system, I had to manually add the path of *TeX commands under "Add to PATH".

To be more exact, since I am using MacPorts, I aded the following entry and everything works as expected:

/opt/local/bin/
share|improve this answer
1  
Welcome to TeX.SX! –  Papiro Jul 30 '13 at 12:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.