Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In my thesis I need a chapter in the appendix, which lists my own papers.

How can I achieve that with the following conditions:

  • biblatex is used
  • it is possible that a paper has already been cited in the text and therefore is in the main bibliography -> it then shall also appear in the appendix
  • most of those papers of my own have not been cited in the text and therefore shall not appear in the main bibliography!
  • the papers for the appendix are marked with the keyword "myPapers"
  • the bibliography in the appendix shall have no heading, but just start where is is placed in the sourcecode with the first reference.

What I tried: I have a working document with a main bibliography at the end (before the appendix), created by \printbibliography.

options:

\usepackage[natbib=true, style=numeric-comp, backend=bibtex8]{biblatex}  

In the appendix I added:

\begin{refsegment}

\printbibliography[keyword=myPapers]
\end{refsegment}

Which had no visible effect at all. (No bibliography created.)

  • Does biblatex recognize, that the papers were already cited?
  • the main bibliography was not in a refsegment-group!

I added a \nocite{Martin2007a, Martin2007b, Martin2008a, etc.} and now the list of papers is ok, however the same papers (also with the same number) appear in the main bibliography, even if they were not cited in the main document!

  • how can I avoid that?
share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

Use a refsection environment instead of refsegment, then you can \nocite{*} all bibliography entries without affection the main bibliography:

\documentclass{article}

\begin{filecontents*}{mybib.bib}
@ARTICLE{notminenotcited,
    author = {Somebody Else},
    title = {Not Mine -- Not Cited}
}

@ARTICLE{notminecited,
    author = {Somebody Else},
    title = {Not Mine -- Cited}
}

@ARTICLE{minenotcited,
    author = {Me},
    title = {Mine -- Not Cited},
    keywords = {myPapers}
}

@ARTICLE{minecited,
    author = {Me},
    title = {Mine -- Cited},
    keywords = {myPapers}
}
\end{filecontents*}

\usepackage[natbib=true, style=numeric-comp, backend=bibtex8,defernumbers, maxnames=99]{biblatex}
\bibliography{mybib}

\begin{document}
\cite{notminecited}, \cite{minecited}

\printbibliography

\appendix

\begin{refsection}
\nocite{*}
\printbibliography[keyword=myPapers,title={My papers}, prefixnumbers={P.}, heading=bibnumbered]
\end{refsection}

\end{document}

(The filecontents* environment is for demonstration purposes only in order to create a self-contained MWE - you can delete it and use your own bibliography file, of course.)

Please note: In this configuration, biblatex creates several auxiliary files, so you'll have to run bibtex8 <filename>.aux and bibtex8 <filename>1-blx.aux - information which commands to call can be found in the log file. (latexmk can do all necessary compiling automatically - also with biblatex.)

If you're using an older version of biblatex (e.g. the one shipped with TeX Live 2010), you'll have to upgrade it to the latest version on CTAN, otherwise the example won't work as expected.

I didn't know how you want to handle the numbering of the entries in the bibliography - I used the defernumbers package option in order to reset the numbers in the list of your own papers - like this, the numbering of the main bibliography and the appendix are completely independent, both start with [1] (this might, however, cause some confusion).

share|improve this answer
1  
thank you! It seems that refsection and defernumbers did the trick! With heading=bibnumbered I also get the corresponding chapter-heading as "appendix A". –  Martin Jul 18 '11 at 21:03
    
p.s. I decided not to use \nocite{Martin2007a, Martin2007b, etc} with an explicit list of papers in my real document instead of \nocite{*}, as my bibliography file is very large (>3000 entries) and so it would produce a 5 MB .bbl file which should IMHO only be bad for performance and compiling time (or is this not true?). –  Martin Jul 18 '11 at 21:19
1  
@Martin heading=bibnumbered gives the bibliography the default title and also invokes \chapter or \section depending on your document class. For no heading you can use heading=none, with none defined as \defbibheading{none}{}. This definition is already done for you as of version 1.5. –  Audrey Jul 18 '11 at 23:04
    
@Audrey: thank you! I had found that myself, finally. The none-option does not work at the moment, as I still have biblatex 1.4 (and need to find out how I can update), but 'bibnumbered' does exactly what I need. (see my edits in diabonas' answer) –  Martin Jul 19 '11 at 7:34
add comment

Hmmm, since you're using bibtex8 as the backend and natbib-style citation commands, do you have the option of forgoing biblatex entirely? If so, you could load the bibunits package to achieve what you're after. Back to biblatex: I'm surprised that none of the examples in section 10.5.3 of the user guide seem to meet your needs.

share|improve this answer
    
I switched to biblatex less than 1 day ago and it was very painful. :-( I was struggling half a night, until it now seems to work without major errors. I tried to use biber as backend, but it did not work yet, so I switched to bibtex8. The natbib=true-option is to avoid all the natbib-citation-commands in my >200 pages to break - I'll try to get rid of it later. –  Martin Jul 18 '11 at 5:09
    
The main problem is to exclude the references from the main bibliography, which are not cited in the document body. The problem is: there are also citations in the appendix, so if I'd define 2 refsegments, the second one would be inside the first one. Is this possible? –  Martin Jul 18 '11 at 5:11
    
I believe biblatex lets you create non-nested refsegment environments, say, one for each chapter of a book, or one for the msinmatter and one for the appendix (or, more exciting still, one for each appendix). That at be what you need in order for all your \nocite elements not to show up in the main bibliography. –  Mico Jul 18 '11 at 10:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.