Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm French so it's not easy to explain my problem but I'll try.

I use fancyhdr to make my own headings (book class).

I want the section's title at the right of the heading in small caps, and only in odds pages. But when I print it I can read e.g., "2. DERIVATION" which is what I was expecting.

My question is: how can I remove the number of the section, so that I can obtain just "DERIVATION" and not "2.DERIVATION"?

I wrote :

\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhead{} % clear all header fields
\fancyhead[LE]{\footnotesize{\scshape\nouppercase{\leftmark}}}
\fancyhead[RO]{\footnotesize{\scshape\nouppercase{\rightmark}}}
\fancyfoot{} % clear all footer fields
\fancyfoot[LE,RO]{\thepage}
\renewcommand{\headrulewidth}{0 pt}
\renewcommand{\footrulewidth}{0 pt}

\leftmark is for chapter and is OK.

The problem is with the \rightmark, how can I redefine it?

share|improve this question
1  
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, then they are marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). –  egreg Jul 26 '11 at 15:07

1 Answer 1

Add the following line to the settings for fancyhdr

\renewcommand{\sectionmark}[1]{\markright{#1}}
share|improve this answer
    
it works thank you a lot !! –  benekire Jul 26 '11 at 15:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.