Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing a large document with equations in LaTeX. I suddenly noticed that a small unusual problem is occurring. I am writing an equation as follows:

\begin{equation}
f_{c}(t) = 1.0 + 0.024 C(t) - 3.5\cdot10^{-3} C(t)^{2} + 2.8\cdot10^{-4} C(t)^{3}
\end{equation}

but the result of this in my final pdf looks like

f_{c}(t) = 1 0 + 0 024 C(t) - 3 5\cdot10^{-3} C(t)^{2} + 2 8\cdot10^{-4} C(t)^{3}

That is, all decimal points disappeared and were generated like a whitespace. I cannot find any reason why this is happening. How can I fix this?


@Herbert concerning Fonts, i am now loading this :

\usepackage{xunicode}
\usepackage{xltxtra}
\defaultfontfeatures{Mapping=tex-text} % converts LaTeX specials (``quotes'' --- dashes etc.) to unicode
\setromanfont [Ligatures={Common}, BoldFont={Times New Roman}, ItalicFont={Times New Roman}]{Times New Roman}
\setsansfont [Ligatures={Common}, BoldFont={Calibri}, ItalicFont={Calibri}]{Calibri}
\setmonofont[Scale=0.8]{Monaco} 

@Seamus my working file looks like this, as an example for equation

\input preamble
\begin{document}
\selectlanguage{english}
\begin{equation}
\epsilon_{clear}(t) = 0.711 + 5.6\cdot10^{-3}\ \vartheta_{dew}(t)
\end{equation}
\end{document}

where my preamble is following layout file:

\usepackage[squaren]{SIunits}
\usepackage{cite,xunicode,xltxtra}    
\defaultfontfeatures{Mapping=tex-text}
\setromanfont [Ligatures={Common}, BoldFont={Times New Roman}, ItalicFont={Times New Roman}]{Times New Roman}
\setsansfont [Ligatures={Common}, BoldFont={Calibri}, ItalicFont={Calibri}]{Calibri}
\setmonofont[Scale=0.8]{Monaco} 

% HEADINGS
\usepackage{sectsty} 
\usepackage[normalem]{ulem}
\chapterfont{\sffamily\bfseries\upshape\Huge}
\sectionfont{\sffamily\bfseries\upshape\Large}
\subsectionfont{\sffamily\bfseries\upshape\large} 
\subsubsectionfont{\sffamily\bfseries\upshape\normalsize} 

\RequirePackage[times]{quotchap}
\renewcommand{\sectfont}{\sffamily\bfseries\upshape\Huge}

\makeatletter
\newcommand\citaat{\if@openright\cleardoublepage\else\clearpage\fi\thispagestyle{plain}}

% chapters that do not start at new page...
\newcommand\chapterNoPageBreak{\thispagestyle{plain}\global\@topnum\z@\@afterindentfalse\secdef\@chapter\@schapter}  
\makeatother

\usepackage[dutch,english]{babel}

\usepackage{fancyhdr,graphicx,listings}
\renewcommand\lstlistlistingname{List of Listings} % default is Listings
\lstset{language=JAVA}

\usepackage{fancyhdr}
\pagestyle{fancyplain}

\usepackage{moreverb}

\addtolength{\headheight}{3pt}         % allow 1 lines in 12pt
\renewcommand{\headrulewidth}{0.4pt}
\renewcommand{\footrulewidth}{0pt}
\renewcommand{\plainheadrulewidth}{0pt}
\renewcommand{\plainfootrulewidth}{0pt}

\renewcommand{\chaptermark}[1]{\markboth{#1}{}}
\renewcommand{\sectionmark}[1]{\markright{\thesection\ #1}}

\lhead[\fancyplain{}{\rm\thepage}]{\fancyplain{}{\rightmark}}
\chead[]{}
\rhead[\fancyplain{}{\leftmark}]{\fancyplain{}{\rm\thepage}}
\lfoot[]{}
\cfoot[]{\fancyplain{\rm\thepage}{}}
\rfoot[]{}

\input{macros.def}

...

share|improve this question

migrated from stackoverflow.com Jul 28 '11 at 16:38

This question came from our site for professional and enthusiast programmers.

closed as not a real question by Joseph Wright Sep 4 '11 at 20:32

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
which font are you loading? –  Herbert Jul 28 '11 at 16:49
    
Please add a minimal working example (MWE) that illustrates your problem. –  Seamus Jul 28 '11 at 17:37
    
This is not a problem of the zoom level in your viewer? The Preview app on Mac OS X sometimes does not show hyphens when zoomed out but they are there. –  Christian Lindig Jul 29 '11 at 7:22
    
@Christian No, it is not a problem of my pdf reader, the dots are actually missing, i.e. in my pdf as well as on paper if i print it :) –  ruben baetens Jul 29 '11 at 7:34
    
Welcome to TeX.sx! Your question was migrated here from another stackexchange site. Please register on this site, too, and make sure that both accounts are associated with each other, otherwise you won't be able to comment on or accept answers or edit your question. –  Martin Scharrer Jul 29 '11 at 8:22

Browse other questions tagged or ask your own question.