Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I don't know what is going on, but I've moved computers and my biblatex bibliography no longer gets printed.

I do the usual:

\addbibresource{references.bib}
\nocite{*}
...
\printbibliography
\end{document}

I am using TeXworks and click on the play button with the "pdfLaTex" selected. But there is no bibliography that gets generated! All it says is:

54 LaTeX Warning: Empty bibliography on input line 54.

which is the line that says \printbibliography.

I am using Windows 7. I tried MikTeX, and just tried TeXworks (from TeX Live) – same thing.

I have no idea what's going on, any help?

share|improve this question
    
i have to ask: did you copy the file references.bib to the new computer??? –  Oz123 Jul 30 '11 at 5:53
    
Yes, it's in the same folder as the file I am compiling "main.tex". –  drozzy Jul 30 '11 at 5:58
    
Did you run latex - bibtex - latex? (Sorry, really a wild guess...) –  Rainer Jul 30 '11 at 10:53
    
@Rainer: thanks for the guess! I converted this into a comment to the question, as the answer space below is reserved for real answers. –  Stefan Kottwitz Jul 30 '11 at 11:12
1  
As Rainer hinted: Compile with "pdflateX", then "BibTeX", then "pdfLaTeX". –  lockstep Jul 30 '11 at 19:43
show 1 more comment

1 Answer

up vote 0 down vote accepted

Ok the problem was that I used bibtex and no "biber" to compile my latex file. I found an answer on SO:

From the topmenu: Build/Define Output Profiles/

Path to bibtex executable: "fill in location of biber.exe"

Command line arguments to pass to Bibtex: "%bm" (is same as main file's full path without extension)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.