Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm writing a document using srcbook. It has quite many pages and I have the following scenario:

The first ~10 pages are numbered with small roman numbers (i.e. i, ii, iii, iv, v, vi, vii, ...). These pages contain preface, table of contents, and such stuff.

After these pages, I continue with ordinary arabic page numbers. The problem however is the following: The first page with arabic numbers is on the left. This results in the face that all \parts and \chapters start on the left page.

However, I would like to start them on the right page.

So, I tried the option openright to enforce new chapters opening on the right page. However, LaTeX seems to check this property according to the page number.

Of course, I can simply insert an empty page to enforce this manually, but this seems like a hack.

Is there any way to acchieve what I want more elegant?

share|improve this question
2  
then there is something wrong with your setting, because openright is the default for a twoside document. –  Herbert Aug 1 '11 at 11:26
1  
Perhaps a minimal example would help? I thought what you wanted was the default behaviour. Are you using \frontmatter and \mainmatter? –  Seamus Aug 1 '11 at 11:28
    
@Herbert Thank you. You were right, I didn't use proper settings. –  phimuemue Aug 1 '11 at 11:28
    
@Seamus Thanks for the hint - it solved the problem. If you add an answer, I'll accept it. –  phimuemue Aug 1 '11 at 11:31
add comment

1 Answer

up vote 7 down vote accepted

Use \cleardoublepage or \frontmatter/ \mainmatterto separate the parts. \newpage alone will confuse latex.

\documentclass{book}

\begin{document}
\frontmatter
\pagenumbering{roman}
 first page
\mainmatter%
%\cleardoublepage
\pagenumbering {arabic}

\chapter{blub}
\end{document}
share|improve this answer
    
Thank you. \frontmatter and \mainmatter solved the problem. –  phimuemue Aug 3 '11 at 8:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.