Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When compiling a LaTeX document with XeTeX, I get the following error:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! You are attempting to make a LaTeX format from a source file
! That is more than five years old.
!
! If you enter <return> to scroll past this message then the format
! will be built, but please consider obtaining newer source files
! before continuing to build LaTeX.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

! LaTeX source files more than 5 years old!.
l.545 ...aTeX source files more than 5 years old!}

? 
! Emergency stop.
l.545 ...aTeX source files more than 5 years old!}

No pages of output.

I invoked the command with xelatex document.tex, what am I doing wrong? LaTeX and XeTeX was installed from repos of Fedora 15, how come those sources are too old?

Edit:

I was asked to provide an example where this error occurs:

\documentclass[pdftex, paper=a4, 11pt]{scrartcl}
\title{title}
\begin{document}
%\maketitle
\section*{test}
blah blah
\end{document}

I could further simplify, if that helps...

share|improve this question
1  
Please submit your minimal not-working example. :-) –  xport Aug 3 '11 at 2:47
    
After changing the global documentclass options (pdftext -> pdftex; a4paper -> paper=a4), this minimal example compiles fine. Check for yourself on ScribTeX. –  Werner Aug 3 '11 at 3:12
    
I can compile it without errors. There are only 2 warnings "pdftext global options are not used". –  xport Aug 3 '11 at 3:13
    
I tried what Werner suggested, didn't help. I changed the minimal example accordingly. –  polemon Aug 3 '11 at 3:19
    
@Werner What you suggest actually not solves his problem. Any undefined options in \documentclass are only unused global options as @xport already showed. The reason you can compile it fine is that you are using a right TeX distribution while @polemon is not –  Yan Zhou Aug 3 '11 at 3:20
add comment

3 Answers

up vote 5 down vote accepted

Nothing is wrong, except the old software. You should upgrade your TeX Live distribution.

share|improve this answer
    
I found a repo for Fedora 14 providing TeX live 2011. I'll try that out and see if it helps. –  polemon Aug 3 '11 at 4:18
add comment

I think this question has been asked by a user using Ubuntu.

The problem is that the TeXlive distributed by most Linux distributions (if not all) is still TeXLive 2007. If everything is from TL2007 it should be fine. But perhaps the maintainer updated some individual binaries, e.g., xetex, without updating everything.

I strongly suggest against using the texlive distribution by Fedora/Ubuntu or whatever. Instead, I suggest you install an up to date TeXlive distribution from the official site http://tug.org/texlive/. You can find everything you need to know about the installation from the same site.

share|improve this answer
1  
I think most distros have TL 2009 now. –  frabjous Aug 3 '11 at 3:27
    
@frabjous It seems it is still 2007. Check the following status page. However I use RHEL so cannot be sure which actually shown up in the package manager in Fedeora 16. Anyway last time I use Ubuntu 10.10 and Fedora 14 it is still 2007 admin.fedoraproject.org/updates/… –  Yan Zhou Aug 3 '11 at 3:31
    
Ubuntu 10.04 (lucid) and higher have TL 2009: packages.ubuntu.com/search?keywords=texlive (8.04 LTS (hardy) obviously only has TL 2007). –  Caramdir Aug 3 '11 at 3:41
2  
It is better to use TeX Live 2011 provided by TUG, not the Linux dist source. –  Leo Liu Aug 3 '11 at 4:47
    
show 1 more comment

Probably the easiest solution to this problem is to temporarily change the system date (of course, this applies only when actually generating formats, after which you can set the date back).

This , of course, only if for some reason you don't want to upgrade your TeX distro.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.