Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the IEEEtran template. I have to cite one reference, this reference has several special math characters, when I tried to convert it to pdf file, LyX gave many errors about it,

Errors: six "undefined control sequence."

Description:
...ncertainty measures for {$\ell^{2}(\mathbb
                                             {R}^{n})$},
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

From the error and description, it should be the title, and the title of reference is :

title="Entropy-Based Uncertainty Measures for {$\ell^{2}(\mathbb{R}^{n})$},
{$\ell^{2}(\mathbb{Z})$}, and {$\ell^{2}(\mathbb{Z}/N\mathbb{Z})$}
with a Hirschman Optimal transform for {$\ell^{2}(\mathbb{Z}/N\mathbb{Z})$}"

However, when I add one special relation symbol \triangleq or complicated binary operators, similar symbols in the body of the LyX file anywhere (not Greek letters), LyX can convert into pdf file smoothly, but leave unwanted symbols in the pdf file.

I don't have anything in the preamble. and the bibliography works with the same author with different paper title, so it is not a problem with the author name but with the math symbols.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You need to load the amssymb package.

(In LyX: choose "document"-->"settings"--> "latex preamble" , copy \usepackage{amssymb} into the empty region on the right side, press "apply" and "close")

share|improve this answer
    
Thanks, I added \usepackage{amssymb} in the preamble, but it still does not work –  Mike Aug 3 '11 at 15:17
    
sorry, I rebooted my computer, added \usepackage{amssymb} back in the preamble, it works. Thank you so much ! –  Mike Aug 3 '11 at 15:28
    
From menu, choose "document"-->"settings"--> "latex preamble" , copy \usepackage{amssymb} into the empty region on the right side, press "apply" and "close", done! –  Mike Aug 3 '11 at 15:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.