Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying compiling this latex template example (CHI Extended Abstracts template) under linux (XeTeX, Version 3.1415926-2.2-0.9997.4 (TeX Live 2010/Arch Linux) using xelatex.

This is the output I'm getting: http://sprunge.us/YaXi

It seems that it's having troubles finding Helvetica, but helvetica is installed: fc-list http://sprunge.us/GChE

Can you guys help?

UPDATE: Trying to simplify the issue, I've been suggested on #latex to try with a simpler example:

\documentclass{scrbook}
\usepackage[english]{babel}
\usepackage{blindtext}
\usepackage{fontspec}
\usepackage{xunicode}
\defaultfontfeatures{Mapping=tex-text}
\setmainfont{Helvetica}


\begin{document}

\Blinddocument

\end{document}

Which fails just as the template above. See http://sprunge.us/GJdG

share|improve this question
4  
You also have Nimbus Sans L installed, which is nearly identical to Helvetica. You could try that. Also, you shouldn't use babel with xelatex, but Polyglossia instead. (Though I've noticed that causes problems for blindtext.) But I don't think that's your problem. –  frabjous Aug 8 '11 at 13:30
    
Try this: \setmainfont{Helvetica Regular} Let me know the result. –  Sam Qasbah Aug 8 '11 at 15:56
    
Yeah, using Nimbus Sans L worked just fine. –  Fabio Varesano Aug 10 '11 at 7:13
2  
@frabjous: We have TeX Gyre Heros now, please don't use the inferior GhostScript fonts anymore. –  Martin Schröder Jun 17 '12 at 21:30
1  
Check the type of the Helvetica fonts you have (fc-list -v Helvetica | grep fontformat). At least here, Helvetica is in PCF, a bitmap font format, which can't be used with Xe(La)TeX, even if listed by fc-list. On how to filter fc-list, and on what may be the same issue, see tex.stackexchange.com/questions/25786/… –  njsg Jun 17 '12 at 21:52
add comment

2 Answers 2

up vote 4 down vote accepted

I suspect your Helvetica font is not properly installed. fontspec easily chokes on fonts that are duplicated for example (two different files providing the same font).

Check your installation.

Also, if you're not picky on the exact font to use, @frabjous' suggestion to use Nimbus Sans L (a free Helvetica clone) is a good idea.

share|improve this answer
    
Yes, this is probably the case.. don't know how can I fix this though. –  Fabio Varesano Aug 10 '11 at 7:12
add comment

I think that

\usepackage{helvet}
\renewcommand{\familydefault}{\sfdefault}

should work. It's worked for me

share|improve this answer
4  
\usepackage{tgheros} please. –  Martin Schröder Jun 17 '12 at 21:32
1  
@MartinSchröder: Why? –  doncherry Jun 18 '12 at 13:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.