Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I type some Romanian characters (ș and ț, to be more specific) in LibreOffice and in LyX, they are not displayed. I just see blank spaces, nothing shows up. However, the same characters are displayed when I type them into Terminal or vim, nano, etc. (I have openSUSE 11.4). Any suggestion might help. Thank you!

share|improve this question
1  
Did you install any fonts to obtain this where it is displayed? You may have to install a font update to accommodate the use of comma diacritics. –  Werner Aug 18 '11 at 18:45
1  
The problem is that it doesn't display the characters ș and ț when I use specific fonts like Times New Roman and Arial. I can use substitutes for s with comma and t with comma (the ones with cedilla), but it is not correct. I've googled this and found that others have similar problems (e.g. ș and ț are displayed differently from other characters in fonts like Arial or Times New Roman). To obtain them I press Right-Alt and s/t respectively, this is the keyboard setting for Linux. It works in Firefox (when I select Times New Roman Font), so I am not sure if the font is the problem. –  chimil Aug 29 '11 at 15:48
1  
Sorry to have seen the question only now; the problem might be in what you use for typesetting: is it XeLaTeX or LaTeX? In the latter case you should pass the option [utf8x] to inputenc, as [utf8] doesn't support the comma-below accent. –  egreg Mar 3 '12 at 22:39
    
Do you mean that they don't appear in the PDF (as @egreg's answer relate to), or in LyX's main window? –  Torbjørn T. Mar 4 '12 at 21:04
    
In LyX and in LibreOffice. –  chimil Mar 9 '12 at 11:26
add comment

1 Answer

up vote 3 down vote accepted

The problem might be in what you use for typesetting: is it XeLaTeX or LaTeX?

In the former case the font might not have the glyphs corresponding to ș and ț.

In the latter case you should pass the option [utf8x] to inputenc, as [utf8] doesn't support the comma-below accent.

share|improve this answer
    
I use XeLaTex, but that's not the issue. Itøs about how they are displayed in LyX and LibreOffice. –  chimil Mar 9 '12 at 11:24
    
@chimil If you use XeLaTeX, then make sure that the font you're using has the glyphs. Maybe somebody can point to a program that you can use on OpenSUSE in order to look up in fonts. It's not clear if the problem is in the printed version or in the LyX preview. –  egreg Mar 9 '12 at 11:27
    
I used fontmatrix. Maybe after I'll upgrade to 12.2 it will make a difference. I will mark this as solved, even though I haven't fixed the issue. Thanks for your reply. –  chimil Mar 9 '12 at 14:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.