Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using natbib.sty chicago.bst as my bibtex style sheets.

My natbib call looks like

\usepackage[numbers,sort&compress,super]{natbib}

when I try to change the hanging indent in my bibliography nothing happens:

\setlength \bibhang{1in}

However, if I remove the numbers and super options from the natbib options, the hanging indent happens? It appears that bibhang doesn't work with the numbers and super options? Any clue whats going on here? I'm stumped and have spent the better part of the afternoon searching for an answer.

share|improve this question
    
Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While it might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. A tip: If you indent lines by 4 spaces, then they are marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). –  doncherry Aug 12 '11 at 0:14
    
Which document class are you using? –  Gonzalo Medina Aug 12 '11 at 0:21

1 Answer 1

up vote 5 down vote accepted

According to the natbib documentation,

The list of references for author–year styles uses a hanging indentation format: the first line of each reference is flush left, the following lines are set with an indentation from the left margin. This indentation is 1em by default but may be changed by redefining (with \setlength) the length parameter \bibhang.

This suggests that \bibhang will have effect with author-year schemes, but you are using the numbers option, so \bibhang won't have any effect.

One possible workaround would be to redefine the thebibliography environment as implemented in report.cls. Here's what you would have to add to your preamble (change the value of \mybibindent according to your needs):

\newlength\mybibindent
\setlength\mybibindent{1in}
\makeatletter
\renewenvironment{thebibliography}[1]
     {\chapter*{\bibname}%
      \@mkboth{\MakeUppercase\bibname}{\MakeUppercase\bibname}%
      \list{\@biblabel{\@arabic\c@enumiv}}%
           {\settowidth\labelwidth{\@biblabel{#1}}%
            \leftmargin\labelwidth
            \advance\leftmargin\dimexpr\labelsep+\mybibindent\relax\itemindent-\mybibindent% new
            \@openbib@code
            \usecounter{enumiv}%
            \let\p@enumiv\@empty
            \renewcommand\theenumiv{\@arabic\c@enumiv}}%
      \sloppy
      \clubpenalty4000
      \@clubpenalty \clubpenalty
      \widowpenalty4000%
      \sfcode`\.\@m}
     {\def\@noitemerr
       {\@latex@warning{Empty `thebibliography' environment}}%
      \endlist}
\makeatother
share|improve this answer
    
I'm using \documentclass[12pt, letterpaper]{report}. I'm trying the specific suggestion given by gonzalo at the moment. –  bcoss Aug 12 '11 at 0:24
1  
@bcoss: see my updated answer. –  Gonzalo Medina Aug 12 '11 at 1:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.