Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I get the error:

! Package hyperref Error: This color specification is not supported
(hyperref)                without package `xcolor' in
(hyperref)                `linkbordercolor=111'.

See the hyperref package documentation for explanation.

I installed it from http://www.ukern.de/tex/xcolor.html under the location:

/usr/local/texlive/2011basic/texmf/tex/latex/xcolor

And put the .pro file under:

/usr/local/texlive/2011basic/texmf/dvips/xcolor

Still getting the error. Any clues?

EDIT:

http://ctan.unsw.edu.au/macros/latex/contrib/xcolor/xcolor.pdf

Usually, you will have to run some kind of filename database update in order to make the files known and quickly searchable to the TEX system

share|improve this question

2 Answers 2

I suppose you have set the color as

linkbordercolor=1 1 1

try it this way:

linkbordercolor={1 1 1}
share|improve this answer
    
Hat tip. I was using a reputable template, tisk tisk. –  Aram Kocharyan Aug 15 '11 at 7:26
1  
@Aram: If linkbordercolor is used as package option all spaces will be removed. Using \hypersetup{..} instead afterwards is more recommended. –  Martin Scharrer Aug 15 '11 at 7:28

Short: To update your TEXMF database run texhash.

Long:

I would always install packages from CTAN, e.g. http://www.ctan.org/tex-archive/macros/latex/contrib/xcolor, in the case of xcolor, but the author's website is of course also fine.

The README file contains installation instructions:

Installation instructions
=========================

Extract all package files:
  `latex xcolor.ins'

Put the generated files to their respective locations
within the TeX installation:
  *.sty -> /tex/latex/xcolor/
  *.def -> /tex/latex/xcolor/
  *.pro -> /dvips/xcolor/

Create the documentation:
  `latex xcolor.dtx'
  `latex xcolor.dtx'
  `makeindex -s gind.ist xcolor.idx'
  `latex xcolor.dtx'
  `latex xcolor.dtx'

Run the test files (N=1,2,...):
  `latex xcolorN.tex'
  `latex xcolorN.tex'

However, TeX Live comes with a package manager called tlmgr (not included in the version delivered by Ubuntu or Debian). With this manager you can install xcolor simply using:

tlmgr install xcolor

Which will update the database as well. Note that you can update all installed packages using:

tlmgr update --self --all

I personally would simply install the full TeX Live (if you have the HD space of ~2.5GB) using:

tlmgr install scheme-full

Then you don't have these issue any longer.

share|improve this answer
    
much easier to install with tlmgr, thanks. –  Aram Kocharyan Aug 15 '11 at 7:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.