Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In plain TeX, \ddot{a} places the double-dot accent correctly above the letter a. However, if I (attempt to) switch from the default (Computer Modern) fonts to ec-lmr10 (I believe that this is Latin Modern?), the double dot accent ends up in the middle of a.

Running pdftex on the code below gives me two correct "double-dotted a", two correct "vectored a", then two wrong "double-dotted a" and two correct "vectored a", so the problem depends on the accent.

$\ddot{a}\mathaccent"707F{a}$
$\vec{a} \mathaccent"017E{a}$
\font\tenrm = ec-lmr10 at 10pt\relax
\textfont0 = \tenrm
$\ddot{a}\mathaccent"707F{a}$
$\vec{a} \mathaccent"017E{a}$
\bye

Two questions: What is causing the diffference? (Some fontdimen parameter, perhaps?) And what am I doing wrong, how could I fix that?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

The font ec-lmr10 is T1-encoded, not OT1. So at position "7F it hasn't the dieresis.

With \mathaccent"7004 you get the right accent.

share|improve this answer
    
Ah, thanks, I feel dumb now :). –  Bruno Le Floch Aug 17 '11 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.