Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Now that I have turned numbering on, \leftmark shows chapter title with number in my header. like

1 ChapterTitle

How do I remove the number?

these are my settings

documentclass[12pt,a4paper,english,openany,oneside]{scrbook}
\usepackage[nouppercase,headsepline,footsepline,automark]{scrpage2}
\clearscrheadfoot
\clearscrheadings
\chead{}
\cfoot{}
\ihead{HeaderLeftText}
\ohead{HeaderRightText}
\ifoot{\rule{0pt}{\ht\strutbox+\dp\strutbox}\SomeChapterNameCommand} % want chapter name here
\ofoot{\rule{0pt}{\ht\strutbox+\dp\strutbox}\thepage}
\pagestyle{scrheadings}
share|improve this question
3  
How exactly are you building your headers? Provide a minimal working code. –  Gonzalo Medina Aug 18 '11 at 15:22
    
No.. I only want to remove the chapter number from the footer text, not the chapter itself. –  umar Aug 19 '11 at 11:22

2 Answers 2

up vote 10 down vote accepted

In case of the KOMA-Script classes, the formatting of the chapter number in the headline is controlled by \chaptermarkformat. To get rid of the chapter number, you simply have to redefine \chaptermarkformat as:

\renewcommand*{\chaptermarkformat}{}
share|improve this answer
    
this answer and \headmark works! –  umar Aug 19 '11 at 12:18

Try redefining \chaptermark:

\renewcommand\chaptermark[1]{\markboth{#1}{}}

If that doesn't work, please add to your question some minimal working code showing the relevant settings involved in the header generation.

share|improve this answer
    
does not work.. added settings –  umar Aug 19 '11 at 11:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.