Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I need a french dictionary. At least, it would be nice to have any information on the location where kile stores its spell-checking dictionaries.

share|improve this question
3  
AFAIK Kile uses an external spell checker (ispell or aspell I think). You need to install the language support for this spell checker first. Which Linux are you using? Are you using Kile under KDE as normal or in another way (e.g. using Gnome)? –  Martin Scharrer Aug 25 '11 at 18:03
add comment

3 Answers 3

Languages including:

Amharic, Arabic, Asturian, Azerbaijani, Belarusianm Bulgarian, Bengali, Breton, Catalan, Czech, Kashubian, Welsh, Danish, German, Greek, English, Spanish, Estonian, Persian, Faroese, French, Frisian, Irish, Scottish, Galician, Ancient Greek, Gujarati, Manx Gaelic, Hebrew, Hindi, Hiligaynon, Croatian, Upper Sorbia, Hungarian, Huastec, Armenian, Interlingua, Indonesian, Icelandic, Italian, Kannada, Kurdi, Kirghiz, Latin, Lithuanian, Latvian, Malagasy, Maori, Macedonian, Malayalam, Mongolian, Marathi, Malay, Maltese, Norwegian, Low Saxonm, Dutch, Chichewa, Oriya, Punjabi, Polish, Portuguese, Quechua Runasimi, Romanian, Russian, Kinyarwanda, Sardinian, Slovak, Slovenian, Serbian, Swedish, Swahili, Tamil, Telugu, Tetum, Turkmen, Tagalog, Setswana, Turkish, Ukrainian, Uzbek, Vietnamese, Walloon, Yiddish and Zulu

I recently ran out to this problem, and this is how i got non-english language spell check working on Ubuntu 13.10, with Kile 2.1.3

1) Run sudo apt-get install aspell

2) Search the right language id from Available Aspell Dictionaries - gnu.org.

3) Run sudo apt-get install aspell-ID, where 'ID' should be replaced with the right language id (see link above)

4) From Configure Kile -> Editing -> Spellcheck -> Default language - drop-down menu select the language you just installed.

5) Check the Automatic spell checking enabled by default tickbox.

6) Click OK to save the settings. I had to press Alt + F7 and move the screen up with arrow keys to see the button.

7) Restart Kile.

Finnish

I tried aspell and myspell spell checkers for Finnish, and they did not have very large volabularies. The best finnish spell checker is Voikko. To install it, follow these steps:

1) Remove any aspell or myspell libraries with

sudo apt-get remove --purge myspell-fi aspell-fi ifinnish ifinnish-large ifinnish-small

2) Install voikko with

sudo aptitude install openoffice.org-voikko libenchant-voikko tmispell-voikko mozvoikko

3) Follow steps 4 to 7 from the generic instructions (above)


! Please feel free to add the best dictionaries for your language above !

share|improve this answer
add comment

For Debian-based Linux systems (including Ubuntu & Co) this should work:

  1. sudo apt-get install kcontrol
  2. sudo apt-get install french
  3. kcontrol

After doing this, you have to activate the language and restart kile and the language should then be changed.

share|improve this answer
    
I've got Fedora. Will this work if I find kcontrol rpm? –  sandman Aug 25 '11 at 19:17
    
Sorry for my late response, but I do not know if this work with fedora. Maybe you can find better help on superuser.com –  Mac-Cherony Aug 29 '11 at 17:58
add comment

First, you need dictionary files (for example for Spanish you need the following files: es_ANY.dic, es_ANY.aff and hyph_es_ANY.dic). The dictionaries for most languages can be found at LibreOffice Extensions page.

Second, copy files es_ANY.dic and es_ANY.aff in the directory /usr/share/hunspell and file hyph_es_ANY.dic in the directory /usr/share/hyphen.

Third, in the directory /usr/share/myspell/dicts create symbolic links to all three files. If you are in the /usr/share/myspell/dicts directory, the symbolic links can be made with:

sudo ln -s ../../hunspell/es_ANY.dic .
sudo ln -s ../../hunspell/es_ANY.aff .
sudo ln -s ../../hyphen/hyph_es_ANY.dic .

Finally, restart Kile and select your newly added language from Tools->Select Dictionary...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.