Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to get the digit one printed the \mathbb{} font in math mode, however the command

\mathbb{1}

outputs some rubbish. I certainly saw the character I am after in some pdf's generated from latex, hence my question: how do you get it to work?

share|improve this question
2  
possible duplicate of How do I make a blackboard 1? –  Gonzalo Medina Aug 27 '11 at 15:04
    
The \mathbb provided as part of the amsfonts package does not provide numerals. Section 3.3 of amsfonts' documentation states that the \mathbb command it provides uses the msbm font and so supports only uppercase letters: no lowercase, no numerals. –  mas Aug 27 '11 at 15:52

2 Answers 2

up vote 24 down vote accepted

Since \mathbb doesn't support digits (with amssymb or txfonts) you may use bbm

\documentclass{article}
\usepackage{bbm}
\begin{document}
\[ \mathbbm{1} \]
\end{document}

bbm example

or dsfont, the doublestroke package:

\documentclass{article}
\usepackage{dsfont}
\begin{document}
\[ \mathds{1} \]
\end{document}

dsfont example

share|improve this answer

Another option is to use bbold package.

\documentclass{article}
\usepackage{bbold}
\begin{document}
\[ \mathbb{1} \]
\end{document}

bbold example

Though it ruins the letters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.