Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Among the IDE's I've tried, TeXShop wins it for me as of now. Except for a small but very important customization: setting the foreground color.

I dig through ~/Library/Preferences and find TeXShop.plist. Somewhere near the bottom of the file, I find some text coloring preferences:

commandblue
commandgreen
commandred

commentblue
commentgreen
commentred

indexblue
indexgreen
indexred

markerblue
markergreen
markerred

background_B
background_G
background_R

If I set the values for the above parameters, they reflect successfully in TeXShop. However, the glitch comes in with:

foreground_B
foreground_G
foreground_R

The foreground_ parameters don't reflect in TeXShop at all. Yes I can go to the Terminal and type

$ defaults write TeXShop foreground_B 0.7
$ defaults write TeXShop foreground_G 0.7
$ defaults write TeXShop foreground_R 0.7

... which still fails.

A different approach
I got this from a rather old (2008) forum post.

  1. Click the "Set ..." button for Document Font.

  2. Click the Text Color button (a "T" with a lime rectangle to the right of it).

  3. [This is the weird bit.] Click the "OK" button in the TeXShop Preferences window without closing the Text Colors window.

  4. Choose a color in the Text Colors window.

Unfortunately, this doesn't seem to save the text color settings -- whenever you restart TeXShop it returns to black text. Alas!

Am I missing something? I hope we can make TeXShop win it some more.

share|improve this question
add comment

2 Answers 2

From the TeXShop Help panel (Hidden Preference Items)

Right before the instructions on setting the text colour of the source window and the colour of the insertion point is the following comment:

Warning: the next two items have not worked since version 2.10. They will be fixed eventually, but probably not in the immediate future.

So unfortunately, I don't think there is a solution to your problem at the moment.

share|improve this answer
add comment

Hit the same rock. The fix was commited to v3.05 (see http://pages.uoregon.edu/koch/texshop/texshop-64/releasenotes-3.05), which is still experimental and only for Lion.

Let's hope that they can backport it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.