TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using lualatex, I get the following error:

</usr/local/share/fonts/HoodHeaven Ornaments Two SSi.ttf>
!LuaTeX error: cannot find OpenType font file for reading ()
 ==> Fatal error occurred, no output PDF file produced!

The file is present and readable:

$ otfinfo -i "/usr/local/share/fonts/HoodHeaven Ornaments Two SSi.ttf"
Family:              HoodHeaven Ornaments Two SSi
Subfamily:           Regular
Full name:           HoodHeaven Ornaments Two SSi
PostScript name:     HoodHeavenOrnamentsTwoSSi
Version:             001.000
Unique ID:           FontMonger:HoodHeaven Ornaments Two SSi
Copyright:           Copyright c 1995 CdExpert Software, Inc. All Rights Reserved.

and the name is correct in the cache:

   ["familyname"]="HoodHeaven Ornaments Two SSi",
   ["filename"]={ "/usr/local/share/fonts/HoodHeaven Ornaments Two SSi.ttf", false },
   ["fullname"]="HoodHeaven Ornaments Two SSi",
    ["family"]="HoodHeaven Ornaments Two SSi",
    ["fullname"]="HoodHeaven Ornaments Two SSi",

What could be going wrong?

share|improve this question

closed as too localized by Joseph Wright Sep 3 '11 at 11:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

</usr/local/share/fonts/HoodHeaven Ornaments Two SSi.ttf> seems to indicate that this font was found. It must be another one which gives problems. Also: if you didn't get an "tfm not found" error, the missing font can't be a system font, it must be one used through pdftex.map. – Ulrike Fischer Sep 2 '11 at 7:39
What versions of luatex/luaotfload do you have? This a backend error, so the font have been found earlier (that is why you don't get a "tfm not found" error) but the backend chocked on it while generating the PDF (my wild guess is that luaotfload is telling the engine it is a CFF font while it is a TTF one). – Khaled Hosny Sep 2 '11 at 9:00
@Khaled this is an up-to-date TL2011 install. – ℝaphink Sep 2 '11 at 9:11
does removing the spaces from file name make any difference? Could you add \directlua{texio.write_nl(font.fonts[font.current()].format, font.fonts[font.current()].psname)} somewhere in your document where this font is selected, and check the log (you should get a line with HoodHeavenOrnamentsTwoSSi and opentype or truetype above it). – Khaled Hosny Sep 2 '11 at 9:27

I saved the ttf-file without spaces and tried it with LuaLaTeX and XeLaTeX and had no problem.

\setmainfont{HoodHeaven Ornaments One SSi}



enter image description here

share|improve this answer
I'm using it with spaces in the name on another machine and it works fine. – ℝaphink Sep 2 '11 at 7:59

It turned out to be a problem with another font (EB Garamond Italic) which was in a bad version in my system. After re-copying this font, everything works fine.

share|improve this answer
'Too localized' on this basis – Joseph Wright Sep 3 '11 at 11:42
Yes indeed. I just had no idea when I asked... – ℝaphink Sep 3 '11 at 15:37
Scary though that a problem with another font file can result in that error message... – jonalv Jan 9 '14 at 17:37
I seem to be having this exact same problem; I have the same error message and it's while trying to use EB Garamond. How did you fix it? – Alex Loomis Feb 2 '14 at 4:55
I removed the font and replaced it again… – ℝaphink Feb 2 '14 at 20:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.