Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In my document (using KOMAScript and babel[ngerman]) I have various figures which get captions like "Abbildung 1: ...".

However, as soon as I add a \appendix to the document all those captions change to "Abbildung 1.: ..." (dot in front of the colon). Apparently this is a feature - I want to disable it anyway!

Using pointlessnumbers in the \documentclass options I can get rid of this dott - but then I also lose the dot in chapter/section numbers which I want to keep since "1. Introduction" looks much better than just "1 Introduction".

share|improve this question

2 Answers 2

up vote 9 down vote accepted

Instead of using the pointlessnumbers class option, remove \autodot from the definition of \figureformat.

\documentclass{scrreprt}

\renewcommand*{\figureformat}{%
  \figurename~\thefigure%
%  \autodot% DELETED
}

\begin{document}

\chapter{bla}

\section{blubb}

\begin{figure}
\centering
\rule{1cm}{1cm}
\caption{A figure}
\end{figure}

\appendix

\chapter{foo}

\section{bar}

\end{document}
share|improve this answer
    
Thanks, that worked. –  ThiefMaster Sep 2 '11 at 13:23

Just had the same problem with the 'dot' in the figure, respectively table.

Found that

\documentclass[numbers=noenddot]{scrbook} 

does the same trick and is much easier than using renewcommands. Just add it to your existing preambles, separated by comma, e.g.

\documentclass[11pt,a4paper,numbers=noenddot]{scrbook}
share|improve this answer
    
The OP wanted to get rid of the closing dots in captions, but wanted to keep the dots for chapters/sections. That's what my \renewcommand was for. :-) –  lockstep Jan 4 '12 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.