Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How do I configure the paths for TexLive2011 to work on my system with TexWorks2011? System: Deb 6 64 bit.

Currently

peter@peter-deb:~$ sudo tlmgr --gui
sudo: tlmgr: command not found
peter@peter-deb:~$ sudo tlmgr update --all
sudo: tlmgr: command not found

enter image description here

I tried

export PATH=$PATH:/home/peter/texlive/2011/bin

but that didn't work.

Note: I asked this question 3 months ago but this is a fresh Deb 6 install and is 64 bit not 32 bit now, so the question is coming at it from a different angle. It would be too confusing to resume the existing thread.

I tried editing .profile in home so please check this for me:

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

PATH=/home/peter/texlive/2011/bin/x86_64-linux:$PATH; export PATH
MANPATH=/home/peter/texlive/2011/doc/man:$MANPATH; export MANPATH
INFOPATH=/home/peter/texlive/2011/doc/info:$INFOPATH; export INFOPATH

@DJP

enter image description here

@DJP Latex-mk appears to be installed properly yet it does not appear in TexWorks processing tools...

  peter@peter-deb:~$ latex -v
   pdfTeX 3.1415926-2.3-1.40.12 (TeX Live 2011)
   kpathsea version 6.0.1
   Copyright 2011 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
   There is NO warranty.  Redistribution of this software is
   covered by the terms of both the pdfTeX copyright and
   the Lesser GNU General Public License.
   For more information about these matters, see the file
   named COPYING and the pdfTeX source.
   Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
   Compiled with libpng 1.5.2; using libpng 1.5.2
   Compiled with zlib 1.2.5; using zlib 1.2.5
   Compiled with xpdf version 3.02pl5
share|improve this question
1  
Does this question help? I mentioned TeXworks lets you configure without setting the path, though others covered that issue, too. –  DJP Sep 3 '11 at 3:12
    
I tried what I thought was the solution - see my profile file above, no luck... –  ptrcao Sep 3 '11 at 3:54
    
In the previous question I said "Start TeXworks, go to the Edit tab, select Preferences and under the Typesetting tab you can use the "+" key to specify the path to your TeX tree. I used the "-" key to remove other options. For me that meant adding /usr/local/texlive/2011/bin/x86_64-linux but since I am using a 64-bit machine, that last item for you might differ." This lets TexWorks find it, though other IDEs will require you to set the PATH. Does that work? –  DJP Sep 3 '11 at 4:07
    
@DJP see above screenshot and tell me if this is correct. Do you know why is Latex-mk missing under processing tools? Shouldn’t it be there if the path has been properly set? (I'm assuming latexmk comes with TL2011)... –  ptrcao Sep 3 '11 at 4:12
1  
let us continue this discussion in chat –  DJP Sep 3 '11 at 4:36
show 2 more comments

1 Answer 1

up vote 3 down vote accepted

On Ubuntu 11.04, a Debian derivative, and Tex Live installed in /home/mas/texlive on an x86_64 system then the following additions at the end of ~/.profile:

PATH=/home/mas/texlive/2011/bin/x86_64-linux:/home/mas/bin/:$PATH; export PATH
MANPATH=/home/mas/texlive/2011/texmf/doc/man:$MANPATH; export MANPATH
INFOPATH=/home/mas/texlive/2011/texmf/doc/info:$INFOPATH; export INFOPATH

get TeX Live working without a problem, including latexmk from the command line.

I have the Ubuntu TeX packages installed as well but, where the same command exists in /home/mas/texlive/2011/bin/x86_64-linux (or in /home/mas/bin/ for some manually-installed software) then that version will be used in preference.

I am using a locally-installed download of TeXworks with the modification you show: In Edit -> Preferences -> Paths frame the path '/home/mas/texlive/2011/bin/x86_64-linux' has been put at the top of the list.

Coming on to latex-mk. This is not in the default list for TeXworks processing tools, although latexmk is (as LaTeXmk on my systems as they are not the latest versions: see the question latexmk-not-accompanying-texworks-0-5 for the change that TeXworks not longer lists latexmk in recent builds). If you want latex-mk and have it installed (it is not part of TeX Live but will probably be in the repositories for many GNU/Linux distributions) then it can be added to the list of processing tools. In TeXworks I added it via Edit -> Preferences in the Processing Tools frame, click '+' to add and fill in the new window appropriately (I used 'LaTeX-mk' for name, 'latex-mk' for program (no path needed unless you have more than one installed and don't want the default), and options '--pdflatex' followed by '$fullname') and that seems to behave reasonably. If you wanted to add any other processing tools the procedure is similar, though the parameters will probably be different, of course.

share|improve this answer
    
Very well explained @mas. Thanks. –  ptrcao Sep 9 '11 at 0:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.