Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Given the directory structure:

B-Galactosidase Report\LaTeX\Min ex\

My .tex file is inside "Min ex" directory.

My .bib file is inside the "B-Galactosidase Report" directory two levels above that.

Then what is the path I should specify for bib.bib in my .tex file? I think the syntax is tripping me up here...

I have tried

\bibliography{"../../B-Galactosidase Report/bib"}{}

which triggers the error

 Non-existent destination files:
      'citing with manual.bbl'
Latexmk: I WON'T RUN 'bibtex citing with manual' because I don't find the following files:
  'bib.bib'
share|improve this question

closed as too localized by egreg, lockstep, Lev Bishop, Stefan Kottwitz Nov 26 '11 at 16:55

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Don't use spaces in any of your directory or file names. Other than that, specifying ../../mybib should work. –  Alan Munn Sep 5 '11 at 7:05
    
I thought spaces should be ok as long as you wrap inverted commas around the pathname? "../../mybib" didn't work in any case... :( –  ptrcao Sep 5 '11 at 7:07
    
No. That is the case with working in Windows' command prompt. Then folders/directories require quotes if they include any special characters, including spaces. –  Werner Sep 5 '11 at 7:10
1  
...I have to ask: Did you try ../../bib? I'm pretty sure it does not matter whether you use / or `` under Windows. –  Werner Sep 5 '11 at 7:18
    
I just tried \bibliography{../../bib}{} and got the same error... What could be wrong? –  ptrcao Sep 5 '11 at 7:32
add comment

2 Answers 2

\bibliography{../../bib}{} is correct and works for me, after I correct an unrelated error. The .aux files needed to be cleared and I needed to ammend the bibliography style, then the above works. Thanks a lot guys for your help!

share|improve this answer
add comment

Ons option is to use the short DOS pathname. Go to the director above "/B-Galactosidase Report" and open a DOS command window. Run the command

dir /X *.*

On my computer it give the short path name of "B-Galactosidase Report" as "B-GALA~1". Now you can use

\bibliography{\detokenize{../../../B-GALA~1/bib}}

If this works then \bibliography{../../bib} should also work

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.