Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a LaTeX document that uses many long pgf paths, and thus compiles only if one increases the TeX "capacity" by setting save_size=50000 in texmf.cnf.

Unfortunately I cannot change the system-wide texmf.cnf directly as I have no root access on my work machine (OpenSuSE 11.3). Is there a way to use a user-defined texmf.cnf that overrides the limits?

share|improve this question
3  
Maybe for some reason you really need to do this but, in my experience, you hardly ever need to "increase LaTeX capacity"; often this just means that there is an error on your .tex file that you should try to solve. Comment out portions of your code until it works, and try to determine what causes the "LaTeX capacity exceeded" error. –  Juan A. Navarro Sep 5 '11 at 8:48
1  
I think I do need to increase LaTeX capacity. On a computer on which I do have root access, my document compiles if I set save_size = 50000 rather than 5000. I am including a pgf path with some 200 points with \input{} multiple times --- or maybe is there a smarter way to do that? –  Federico Poloni Sep 5 '11 at 8:57
1  
I see a -save-size=N option in my pdflatex command (MiKTeX 2.9). Does that help? –  Paulo Cereda Sep 5 '11 at 11:46
2  
@Federico, Indeed you might then need to do this. I only wanted to add that disclaimer for people stumbling with this question while googling how to "increase LaTeX capacity". –  Juan A. Navarro Sep 5 '11 at 15:46
2  
You can increase the memory size locally by editing a local texmf.cnf. The trick is that you need to regenerate the formats using fmtutil after changing the sizes. This answer Memory settings with MacTeX outlines the steps for doing this with root access; you can follow the same steps for modifying a local texmf.cnf provided you use fmtutil instead of fmutil-sys. –  Alan Munn Sep 5 '11 at 16:17

1 Answer 1

up vote 8 down vote accepted

I had the same requirement when I worked with pgfplots - and I found a way.

The resulting steps have made their way into the pgfplots manual, compare the pdf at http://pgfplots.sourceforge.net/

For your convenience, I post a copy of the section about TeX-Live here, it will probably answer your question:

6.2.2 TEXLive or similar installations For Unix installations, one needs to adjust config files. This can be done as follows:

  1. Locate texmf.cnf on your system. On my Ubuntu installation, it is in /usr/share/texmf/web2c/texmf.cnf.

  2. Either change texmf.cnf directly, or copy it to some convenient place. If you copy it, here is how to proceed:

    keep only the changed entries in your local copy to reduce conflicts. TEX will always read all config files found in its search path.

    Adjust the search path to find your local copy. This can be done using the environment variable TEXMFCNF. Assuming your local copy is in~/texmf/mytexcnf/texmf.cnf, you can write

        `export TEXMFCNF=~/texmf/mytexcnf:`
    

    to search first in your directory, then in all other system directories.

  3. You should change the entries


       main_memory = n
       extra_mem_top = n
       extra_mem_bot = n
       max_strings = n
       param_size = n
       save_size = n
       stack_size = n

The log­file usually contains information about the parameter which needs to be enlarged.

An example of this config file thing is shown below. It changes memory limits.

  1. Create the file ~/texmf/mytexcnf/texmf.cnf (and possibly the paths as well).

       % newly created file ~/texmf/mytexcnf/texmf.cnf:
       % If you want to change some of these sizes only for a certain TeX
       % variant, the usual dot notation works, e.g.,
       % main_memory.hugetex = 20000000
       main_memory = 230000000 % words of inimemory available; also applies to inimf&mp
       extra_mem_top = 10000000      % extra high memory for chars, tokens, etc.
       extra_mem_bot = 10000000      % extra low memory for boxes, glue, breakpoints, etc.
       save_size = 150000     % for saving values outside current group
       stack_size = 150000      % simultaneous input sources
       %  Max number of characters in all strings, including all error messages,
       %  help texts, font names, control sequences. These values apply to TeX and MP.
       % pool_size = 1250000
       %  Minimum pool space after TeX/MP's own strings; must be at least
       %  25000 less than pool_size, but doesn't need to be nearly that large.
       % string_vacancies = 90000
       %  Maximum number of strings.
       % max_strings = 100000
       %  min pool space left after loading .fmt
       % pool_free = 47500
  1. Run texhash such that TEX updates its ~/texmf/ls-R database.

  2. Create the environment variable TEXMFCNF and assign the value ~/texmf/mytexcnf: (including the trailing : !). For my linux system, this can be done using by adding

    export TEXMFCNF=~/texmf/mytexcnf:

    to ~/.bashrc.

Unfortunately, TEX does not allow arbitrary memory limits, there is an upper bound hard coded in the executables.

share|improve this answer
    
And running fmtutil with the new texmf.cnf isn't necessary? –  Alan Munn Sep 5 '11 at 20:17
    
I have never run fmtutil. Does texhash run fmtutil? I have always used texhash. But: I always used my user privileges, which are essentially neither root nor sudo. –  Christian Feuersänger Sep 5 '11 at 20:29
    
No, texhash doesn't rebuild formats, it just updates the static ls-R databases. –  Alan Munn Sep 5 '11 at 20:42
    
Wonderful - this works, and seems a "clean" solution. I confirm that I needed no fmtutil and no texhash either, just the file and the environment variable. –  Federico Poloni Sep 6 '11 at 7:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.