Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing a document , A4, using KOMA-Scripts (scrbook) and inside my document i have a Flowchart which doesn't pass in portrait. I used

 \KOMAoptions{paper=landscape}
 \recalctypearea
 \newgeometry{left=20mm,right=20mm,top=20mm, bottom=20mm}

and at the end of the Flowchart, for returning to portrait, i write

 \KOMAoptions{paper=portrait}
 \restoregeometry
 \recalctypearea

doing this give me what i want, but i get the following Warning:

Package typearea Warning: Bad type area settings!
(typearea)               The detected line width is about 48%
(typearea)               larger than the heuristically detected line width.
(typearea)               You should e.g. decrease DIV, increase fontsize
(typearea)               or change papersize.


Package typearea Warning: Typearea changed!
(typearea)                You should do this only at preamble, because only
(typearea)                \begin{document} calculates output dimensions!
(typearea)                Trying to calculate new output dimensions, but
(typearea)                this is only a dirty hack on input line 206.


Overfull \hbox (211.8935pt too wide) in paragraph at lines 314--315
 [] 
[4
Non-PDF special ignored!]

Package typearea Warning: Typearea changed!
(typearea)                You should do this only at preamble, because only
(typearea)                \begin{document} calculates output dimensions!
(typearea)                Trying to calculate new output dimensions, but
(typearea)                this is only a dirty hack on input line 321.

How could i solve this warning due to \recalctypearea?

Remark I know that Overfull \hbox is ... is due to something else

share|improve this question
    
Is this not possible using the geometry package? –  Werner Sep 5 '11 at 17:04
    
Why don't you just use the sidewaysfigure environment from the rotating package? –  Thorsten Donig Sep 5 '11 at 17:17
1  
@Werner: geometry isn't able do use landscape with newgeometry –  Marco Daniel Sep 5 '11 at 17:44
    
You could also use the lscape or pdflscape packages. –  Alan Munn Sep 5 '11 at 17:55

1 Answer 1

You can't disable the warnings. This behaviour is based on the algorithm of typearea / \recalctyparea. \recalctypearea performs its calculations with the last page settings. But by using landscape, the changes to \textwidth and \textheight are more than 15%. (This is the allowed penalty). typearea ignores the modification of the page orientation. Maybe in the next release Markus Kohm will add such a feature.

share|improve this answer
    
Does it mean that way i do it is correct? or is there a better way to switch between portrait to landscape in a KOMA-Script dokument? –  Eagle Sep 5 '11 at 21:44
    
@Eagle: Everything is ok ;-). Markus Kohm offers the same solution on his German website. –  Marco Daniel Sep 5 '11 at 21:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.