Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm creating a resumé using the res.cls package and need to make the left and bottom margins smaller. I know I can use e.g. \topmargin=-0.5in to decrease the space at the top of the page, but neither \bottommargin nor \leftmargin, used similarly, have the same effect.

I've also tried \usepackage[margin=1.0in]{geometry} with no effect (and errors from the keyval package in the TeX log output).

Does anyone know of a way to set the margins for documents created using res.cls?

Edit (09/08):

I found an old email thread from 2006 that made me go "duh!". Both res.cls and geometry try to handle the margin option. I guess I have to somehow send geometry the value instead of the class option, but I don't know how to do that.

share|improve this question

3 Answers 3

up vote 4 down vote accepted
\documentclass{res}
\usepackage[margin=1.0in]{geometry}
\begin{document}
foo\par\vfill bar
\end{document}

Works for me. Can you provide a minimal working example?

share|improve this answer
    
I'm using the margin option in res.cls, which appears to be what's screwing it up. I updated the question. –  dgw Sep 9 '10 at 0:56
2  
You can use \makeatletter\def\@classoptionslist{}\makeatother to clear the class options, but res.cls does not play nice with geometry. It was designed for LaTeX 2.09 and copyrighted 1989. You should consider using something a bit newer. CVs and résumés have been discussed on tex.se in several places. –  TH. Sep 9 '10 at 4:18
    
I have one or two more recent packages to play with, which I can do later. Thanks for your help. –  dgw Sep 16 '10 at 23:10
    
I'm accepting your answer because the problem is solved. Not using res.cls's margin option would have fixed it, and switching to the moderncv package has helped immensely. So your answer and comments have been very helpful. Thanks again! –  dgw Oct 5 '10 at 21:01
\documentclass[margin,line]{res}
\topmargin=-0.5in
\oddsidemargin -.5in
\evensidemargin -.5in
\textwidth=6.0in
\itemsep=0in
\parsep=0in

This worked for me. The first two lines would suffice for your problem.

share|improve this answer

To overcome the margin issue with using the resume document type, I used the following set of options on my one page document:

\topmargin=-0.25in
\addtolength{\textwidth}{.5in}
\addtolength{\textheight}{.5in}
\addtolength{\oddsidemargin}{-.5in}

However, this will not exactly work on a multiple page document. Perhaps add \evensidemargin as well? Also, note that I didn't use the geometry package because I got an error "No value specified for margin".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.