Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having a problem with my LaTeX output that is not printing the bibliography part. I am using Kile to code it. The strange thing is that, it was working out of the box before I reinstalled Ubuntu. After Ubuntu reinstallation, it does not work at all.

A minimal example added by Marco

\documentclass{article}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{test,
author={John Smith},
title={TITLE},
year={2011},
publisher={...},
}
\end{filecontents*}
\begin{document}

\cite{test}
\bibliography{\jobname}
\bibliographystyle{IEEEtran}

\end{document} 

Everybody should consider I have another file of biblioFile.bib in the same directory as my LaTeX source file.

share|improve this question
    
You have to run bibtex. You can find it under View=>Compile=>bibtex or use the shortcut ALT+-. –  Marco Daniel Sep 8 '11 at 15:43
    
For anyone to be able to help you, you need to supply a minimal working example (MWE) so that someone would be able to reproduce the problem. Otherwise, it would be virtually impossible to follow your technical footsteps and solve the problem. –  Werner Sep 8 '11 at 15:44
    
I've run already using the quickbuild. My quickbuid setting is as follows: PdfLaTeX, PdfLaTeX, BibTeX, BibTeX, PdfLaTeX, PdfLaTeX. –  Shah Sep 8 '11 at 15:46
    
@Shah: I edited your post. Now you have a minimal example. Does it work for you? –  Marco Daniel Sep 8 '11 at 16:17
    
@Marco: It still doesn't work after trying the minimal example..it returns a single "?". –  Shah Sep 8 '11 at 16:33

2 Answers 2

up vote 4 down vote accepted

After running bibtex command, I encountered an error message as follows:

This is BibTeX, Version 0.99c (TeX Live 2009/Debian) The top-level auxiliary file: rr6.aux I couldn't open style file IEEEtran.bst ---line 4 of file rr6.aux : \bibstyle{IEEEtran : } I'm skipping whatever remains of this command I found no style file---while reading file rr6.aux 

This gave a clue to me, I was thinking there might be some missing packages..and after trying to search for "IEEEtran" keyword in the synaptic manager, I found "texlive-publishers" that could be related. After installing it, it turned out that it is again working :-)

Credit should go to Marco for guiding me to fix this. He has provided a very good troubleshooting procedure :-)

share|improve this answer

I had the same problem. Uninstalled and installed "texlive-publishers" as suggested above, and now the whole thing stopped to work! Most of my packages and fonts were removed and weren't re-installed. I had to spend 2 hours to see what is missing (texlive-extra packages, texlive recommended fonts, etc) to reset to the previous installation. Now I am back to something like the previous installation, but the error is still there : "I couln't open style file IEEEtr.bst". I changed the style file name to IEEEtran, called IEEEtran, and removed manually .aux file and it worked.

share|improve this answer
    
good to hear that :-) –  Shah Feb 14 '12 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.