Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

It seems like everytime I install textlive distro on one of my computers I have the same problem:

peter@msideb:~$ tlmgr --gui
bash: tlmgr: command not found

The below reflects the current state of my .profile:

    # ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

PATH=/home/peter/texlive/2011/bin/i386-linux:/home/peter/bin/:$PATH; export PATH
MANPATH=/home/peter/texlive/2011/texmf/doc/man:$MANPATH; export MANPATH
INFOPATH=/home/peter/texlive/2011/texmf/doc/info:$INFOPATH; export INFOPATH

My system: Deb 6 testing, 32 bit, xfce desktop environment.

And yes, I did log off after I edited the .profile file.

Yes, I appear to have the .bashrc file:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# don't overwrite GNU Midnight Commander's setting of `ignorespace'.
HISTCONTROL=$HISTCONTROL${HISTCONTROL+:}ignoredups
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
#[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    #alias grep='grep --color=auto'
    #alias fgrep='fgrep --color=auto'
    #alias egrep='egrep --color=auto'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi
share|improve this question
    
Isn't the usual install location would be \usr/texbin? If you type the PATH command into your shell manually, does which tlmgr find it? –  Peter Grill Sep 9 '11 at 2:11
1  
I believe a similar question was answered in this forum here. Although the question pertains to setting up KILE, you'll find that the answer with the most votes explains how to generically set up the path of TeXLive for all users. See if that helps. –  Bill Sep 9 '11 at 2:41
    
@Peter Grill: How do you mean? What should I type into my terminal to do what you propose? Also I installed to /home/peter/texlive/2011, so isn't that going to be my path? –  ptrcao Sep 9 '11 at 2:45
1  
I was suggesting that you cut and paste the PATH command from your .profile into your command line and see if that sets the path correctly. If so, then you need to find out why the .profile is not being executed. If it doesn't result in the correct path, then you need to fix that path. –  Peter Grill Sep 9 '11 at 3:05
    
Can you run $ echo $PATH and post the result? By the way, on the third line from the bottom of your .profile, you do not need to specifically include /home/peter/bin in your path, it should already be included by the conditional block immediately above that. –  Jan Hlavacek Sep 9 '11 at 4:02
show 8 more comments

2 Answers 2

Mybe you can install TeXLive 2011 in /usr/local/texlive, and make symlinks for all the executables in /usr/local/bin. That way you don't have to alter $PATH.

share|improve this answer
1  
I cannot emphasize enough that this is the proper Unix-y way of adding programs that install to /usr/local/<name>/<loads of directories here>/ to $PATH. Remember to make them soft links (ln -s) - it makes it much easier to tell what's going on when you later come back to /usr/local/bin –  kahen Oct 19 '11 at 11:09
    
This seems to be the better way to do it. Would you be able to elaborate on this answer a bit by adding some steps? –  Magpie Feb 16 '13 at 21:06
add comment

Create as root a file named zzz-texlive.sh with the contents:

    export PATH=/usr/local/texlive/2011/bin/i386-linux:$PATH
    export MANPATH=/usr/local/texlive/2011/texmf/doc/man:$MANPATH
    export INFOPATH=/usr/local/texlive/2011/texmf/doc/info:$INFOPATH
    unset TEXINPUTS
    unset TEXMFCONFIG

Change the i386-linux to your personal directory name. Then save the file in the directory /etc/profile.d/. This script will be executed with every system start.

Finally, delete the lines in your ~/.bashrc which sets any path for texlive.

share|improve this answer
1  
Delete which lines in my .bashrc? –  ptrcao Sep 9 '11 at 8:55
1  
@ptrcao delete the lines about adding to the PATH. –  ℝaphink Sep 9 '11 at 8:59
1  
@Raphink: I can't find any explicit reference to PATH in my .bashrc file. See my original post for the contents of the file and please let me know what lines to remove. –  ptrcao Sep 9 '11 at 9:03
1  
@Raphink + @ Herbert: I'm afraid it didn't work... I did what Herbert said. Ideas? –  ptrcao Sep 9 '11 at 9:22
2  
That may be because bash reads .bashrc every time an interactive shell is started, while it reads .profile only when it is a login shell and interactive shell at the same time, or when it is invoked with the --login option. It seems that when you log in with your display manager, that does not happen. It could be a bug or a configuration problem with your display manager. –  Jan Hlavacek Sep 9 '11 at 10:36
show 20 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.