Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Just installed the latest siunitx and it says that expl3 is too old. I looked on the miktex package update manager and I appear to have the latest version of everything.

The package that now contains the expl3.sty file is l3kernel and it says that it was packaged on 2011-07-11 and installed on 2011-07-20.

Not sure what to do. I need to compile and submit my thesis in a couple of days.

share|improve this question
3  
Update the entire installation, l3kernel has been updated several times since July. –  daleif Sep 12 '11 at 11:55
1  
As @deleif says, there has been a re-arrangement and the code is now in l3kernel and l3packages. To get MiKTeX to install these you need to sync. your package repository. –  Joseph Wright Sep 12 '11 at 12:05
    
i have sync.ed the repository, but it still says the latest version is 11th July. I have found a temporary solution, though I can't be sure if there are some subtle problems caused by it. I managed to install the latest (sept 5th) version of l3kernel from the ctan website. but it is experimental apparently. Sorry Joseph, i left a kind of awkwardly phrased note on your bitbucket site. I was panicking a bit :S –  aghsmith Sep 12 '11 at 14:18

1 Answer 1

The solution I found for this involved finding and downloading the relevant package on ctan. I had previously had trouble extracting the .dtx and .ins type files that are distributed with. The problem it seems was that my latex distribution is in "c:\program files" and the spaces cause problems.

I could imagine other people will have had this problem so in the more general case of updating a package manually under windows, try:

1) put your install file/files in a folder directly under c:\ 2) run latex <package>.idx or latex <package>.ins 3) copy the generated .sty files out of the folder and either put them in the relevant folder in the latex installation. (which I gather is bad practice) or in: C:\Documents and Settings\<user name>\Application Data\MiKTeX\<version>\<package name>\

Though I haven't verified that the second choice will work.

I realise that I have actually answered a different question here, and it's slightly cack handed. It might be able to help some though and hopefully I can edit this answer if more experienced users are at odds with what I've said.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.