Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a long-standing problem with the button produced by the \movieref command from movie15 package. Briefly saying, it does not work at all if my document is compiled with XeLaTeX whereas the button operates as described in the movie15 manual if my document is compiled with pdflatex. Note that the source files for PdfLaTeX and XeLaTeX are slightly different. For XeLaTeX the document preamble contains

\usepackage[dvipdfmx]{movie15_dvipdfmx}

and for PDFLaTeX I am using

\usepackage{movie15}

Other chunck of code is the same for both cases. First, I declare a \RunVideo command that is just an image used for the button:

\DeclareRobustCommand*{\RunVideo}{\raisebox{-0.25\height}\includegraphics[width=1.5em]{icon_video.png}}}

Next I include my movie:

\includemovie[
    label=movie-04-03
    ,mouse=true
        % Enables mouse interaction: Clicking onto the media
        % (giving it the focus) pauses the playback while clicking
        % outside resumes it. Alternatively, once the media has
        % got the focus, repeated pressing of key ‘P’ on the keyboard
        % switches between Play and Pause (at least with some players).
    ,text={\includegraphics[width=\textwidth]{2010-04-03.png}}
]{}{}{Video/2010-04-03-xvid.avi}

And finally the button goes here:

\movieref[pause]{movie-04-03}{\RunVideo}

If the document is compiled with PDFLaTeX clicking the button image cyclically starts/stops/resumes playback. Playback can also be stopped/resumed by clicking onto/outside the movie area. If the document is compiled with XeLaTeX only the second methods works, and clicking on the buttom has no effect at all.

Can someone explain if the code has some drawback of it is a bug of the movie15_dvipdfmx package?

share|improve this question
3  
movie15 has been superseded by media9, and XeTeX is mentioned in the manual. Does this new package work for you? –  Joseph Wright Mar 24 '12 at 7:54
    
@Joseph Wright: media9 does not play my avi file encoded with xvid codec although movie15 did that. I tried examples that come media9 and they work fine. I have several avi files made using same technology (exported avi from Wolfram Mathematica and then encoded using VirtualDub) therefore I didnot tried any other codecs yet. –  Igor Kotelnikov Mar 26 '12 at 16:53
    
I think without the avi file that causes the error it is hard to help you. Can you provide a running MWE with your avi file? –  Kurt Sep 17 '12 at 8:04
add comment

closed as too localized by egreg, lockstep, percusse, Tom Bombadil, Heiko Oberdiek Oct 6 '12 at 23:46

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.