Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the MTPro2 fonts with amsbook class. However something strange happens when I activate the mtpfrak option for the alternate fraktur fonts. LaTeX simply ignores it! That is I see the old AMS fraktur fonts. If I change the document class to memoir, report or book the problem goes away! Has anyone seen this problem before?

share|improve this question
1  
Hi! Just a quick observation: I can replicate your problem for the amsart documentclass as well. :-( –  Mico Sep 14 '11 at 12:16
3  
if this doesn't work with amsbook, it won't work with any other ams document class (amsart, amsproc and all author package classes). i can't remember than anyone has ever asked for these classes to be checked for compatibility with the MTPro2 fonts. i will look into it. –  barbara beeton Sep 14 '11 at 13:25
    
i have tested an example document with amsart and \usepackage[mtpfrak]{mtpro2}. "ordinary" \mathfrak is produced with no complaint, and the output looks good. but if i try to use the alternate forms (\altx et al.), there is a complaint Package mtpro2 Warning: Invalid use of \altx on input line .... on the other hand, the alternate script letters work just fine. i am puzzled, but will continue to investigate. –  barbara beeton Sep 14 '11 at 19:48
    
Thank you, my wording is bad in above. You see, mtpro2 has another complete set of fraktur alphabet which you can use if you load the mtpfrak option. My complaint is that this font does not appear, even after enabling the option. One only gets the computer modern fraktur fonts. –  Hesam Sep 22 '11 at 23:16

1 Answer 1

up vote 4 down vote accepted

I have seen the same issue but can circumvent it by using

\usepackage[frak=mt]{mathalfa}

instead of

\usepackage[mtpfrak]{mtpro2}

whence the trivial example

\documentclass{amsart}
%\usepackage[mtpfrak]{mtpro2}
\usepackage[frak=mt]{mathalfa}
\begin{document}
\[ \mathfrak{ABCDEFGHIJKL abcdefghijklm} \]
\end{document}

produces a pdf that evince reports as having CMR7 and MT2MFT fonts, as intended.

A similar example using amsbook has the following in the output log:

</home/mas/texlive/2011/texmf-dist/fonts/type1/public/amsfonts/cm/cmr7.pfb></ho
me/mas/texlive/2011/../texmf-local/fonts/type1/pctex/mtpro2/mt2mft.pfb>
Output written on mtproamsfrak.pdf (1 page, 20064 bytes).

Moving the '%' down to the next line in both examples results in the AMS frak font being used:

</home/mas/texlive/2011/texmf-dist/fonts/type1/public/amsfonts/cm/cmr7.pfb></ho
me/mas/texlive/2011/texmf-dist/fonts/type1/public/amsfonts/euler/eufm10.pfb>
Output written on mtproamsfrak.pdf (1 page, 22155 bytes).
share|improve this answer
1  
This is a great solution to a disturbing problem! –  Mico Sep 14 '11 at 17:41
    
Thank you this works but given the fact what they charge for mtpro2 I did not expect such problems ... –  Hesam Sep 22 '11 at 23:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.